Incorrect black/white levels on YouTube

RESOLVED DUPLICATE of bug 1161349

Status

()

RESOLVED DUPLICATE of bug 1161349
4 years ago
4 years ago

People

(Reporter: smrank, Unassigned)

Tracking

36 Branch
x86_64
Windows 8.1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(5 attachments)

(Reporter)

Description

4 years ago
Created attachment 8554549 [details]
Black level example (taken in Firefox 36 beta with html5 player)

The black/white levels in the YouTube html5 player are wrong in Firefox. Black pixels are shown as dark grey and white pixels are shown as light grey. This affects Firefox html5 but not Internet Explorer or Flash. See the attached pictures for an example. I was using the following trailer to test but trying others showed the same problem:

https://www.youtube.com/watch?v=IOUk2y0K2m8

I can work around this on my PC as follows:
1. Open NVIDIA Control Panel.
2. Click "Adjust video colour settings".
3. Select "With the NVIDIA settings", go to the advanced tab and change dynamic range to 0-255.
4. Click Apply.

This is on Windows 8.1 64-bit with NVIDIA 347.25 drivers using Firefox 36 beta. I'm also using a 1920x1200 monitor which makes it easier to spot the problem as I get two sets of black bars when playing letterboxed 1080p content.
(Reporter)

Comment 1

4 years ago
Created attachment 8554551 [details]
Black level example (taken in Internet Explorer 11 with html5 player)
(Reporter)

Comment 2

4 years ago
Created attachment 8554552 [details]
Black level example (taken in Internet Explorer 11 with Flash player)
(Reporter)

Comment 3

4 years ago
Created attachment 8554554 [details]
White level example (taken in Firefox 36 beta with html5 player)
(Reporter)

Comment 4

4 years ago
Created attachment 8554555 [details]
White level example (taken in Internet Explorer 11 with html5 player)
(Reporter)

Updated

4 years ago
On an Nvidia card with recent drivers, this can be worked around by going into the Nvidia Control Panel, going to the "Adjust video color settings" tab, setting it to "With the NVIDIA settings", going to the Advanced tab and setting the Dynamic range to "Full (0-255)".

Apparently something in the pipeline assumes that the output device is a limited range monitor like most TVs. But this is not true for your average computer monitor.
Oh, I'm sorry - I totally missed the workaround in the first post. I can confirm that it works however.
Well, Jean-Yves. Here's a vote for PC levels in decoding. :)
This issue to me seems more to do with that nvidia default to studio levels rather than PC levels.

It's the same problem on linux and their VDPAU decoder, you need to explicitly set the decoder to PC levels.

Comment 9

4 years ago
that work around does seem to work.. still shouldn't need to have to do that really.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1161349
You need to log in before you can comment on or make changes to this bug.