With focus-follows-mouse, dropdown lists are hard to use

RESOLVED WORKSFORME

Status

()

Core
XUL
RESOLVED WORKSFORME
16 years ago
16 years ago

People

(Reporter: Michal 'hramrach' Suchanek, Assigned: jag (Peter Annema))

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
0.9.6 Win32 - WinNT4sp6 - point to focus

To reproduce:
1) install TweakUI from PowerToys (I can post some pictures of installation if
they are wanted ;-) http://webusenet-ny.tucows.com/system/adnload/194340_74433.html
(be warned that this is a self-extractor with no directory structure)
2) enable "focus follows mouse" in TweakUI Mouse card
3) run Mozilla
4) try using a dropdown list (ie the OS dropdown on Enter bug page)

Results:
-if you click it, it drops down
  -if after that you move your mouse into the list, it rolls up again
-if you press mouse on the list, the list drops down and you can select an item
by dragging to it and releasing the mouse
-if you press mouse on the list, drag to scrollbar of the list and release
there, you can use the list as usual after this operation

Expected: normal dropdown operation

Note: it seems that some special dropdowns (or dropdowns w/o scrollbar?) like
Location Bar or search engine in Search sidebar work as usual
Sounds like evil focus issues....
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

16 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.1

Comment 2

16 years ago
actually, this works for me on win2k. We did fix this some time ago. don't know 
why it doesn't work in your case (although note that it will roll up if you 
focus another window, which you can accidentally do if the scrollbox is close 
to the window's border). 
(Reporter)

Comment 3

16 years ago
This is not the case. I have the list in the middle of large browser window.

Updated

16 years ago
Summary: In point-to-focus dropdown lists in Mozilla are hard to use → With focus-follows-mouse, dropdown lists are hard to use

Comment 4

16 years ago
Reporter: is this still a bug in new builds?  I fixed all the X-Mouse problems
on Windows that I could find a while back.
(Reporter)

Comment 5

16 years ago
Unfortunately I have no longer a NT4 machine and this seems NT4 specific.

Comment 6

16 years ago
--> default component owner
Assignee: hyatt → jaggernaut
Status: ASSIGNED → NEW
Target Milestone: mozilla1.1alpha → ---

Comment 7

16 years ago
Marking WFM, since I fixed all known problems with X-Mouse and drop downs on
Windows.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.