Closed Bug 1125901 Opened 7 years ago Closed 7 years ago

Some classinfo cleanup.

Categories

(Core :: DOM: Core & HTML, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla38
Tracking Status
firefox38 --- fixed

People

(Reporter: Ms2ger, Assigned: Ms2ger)

References

Details

Attachments

(4 files)

No description provided.
They are equivalent to the WrapNative functions on nsContentUtils.
Attachment #8554656 - Flags: review?(jst)
This is pretty poor behaviour in any case, and it blocks the removal of the
outparam in my next patch.
Attachment #8554657 - Flags: review?(jst)
nsIXPConnectJSObjectHolder is a relic from times long past. It is now safe to
return a JSObject through an outparam, and the JSObject is all the callers
need.
Attachment #8554658 - Flags: review?(jst)
It is now unused, so can be removed.
Attachment #8554660 - Flags: review?(bobbyholley)
Attachment #8554660 - Flags: review?(bobbyholley) → review+
Attachment #8554656 - Flags: review?(jst) → review+
Attachment #8554657 - Flags: review?(jst) → review+
Attachment #8554658 - Flags: review?(jst) → review+
Duplicate of this bug: 958651
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.