Clicking on "Download" on Mozilla page showing Version 35.0.1 Notes incorrectly returns "Congrats! You’re using the latest version of Firefox."

REOPENED
Unassigned

Status

www.mozilla.org
General
REOPENED
3 years ago
a year ago

People

(Reporter: mark, Unassigned)

Tracking

Production
x86
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:35.0) Gecko/20100101 Firefox/35.0
Build ID: 20150108202552

Steps to reproduce:

Went here: https://www.mozilla.org/en-US/firefox/35.0.1/releasenotes/
And then clicked on "Download" on the right hand side.

Clicking on "Download" on Mozilla page showing Version 35.0.1 Notes incorrectly returns "Congrats! You’re using the latest version of Firefox."


Actual results:

URL of the page returned: https://www.mozilla.org/en-US/firefox/new/
Text on the page returned:  Congrats! You’re using the latest version of Firefox.
Choose Independent.
Choose Firefox.



Expected results:

Download of 35.0.1
Note that (in Max OS X 10.9.5), while in Firefox, when I select "About Firefox" from the "Firefox" drop-down, it says my currently-installed release is 35.0.

Comment 1

2 years ago
Hi Mark,

Thanks for tacking time to report the problem and sorry no one got to this sooner. Do you still have problems with this?
Flags: needinfo?(mark)

Comment 2

2 years ago
Mark, please post here information about this bug, don't send me private mail. Thank you.

Comment 3

2 years ago
Hi,
Marking this as Resolved: Incomplete due to the lack of response from the reporter.
Reporter, please feel free to reopen it if you are still having this issue on the latest Firefox version.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(mark)
Resolution: --- → INCOMPLETE

Comment 4

a year ago
This bug is happening to me right now

The Software Update pop up window popped up, and says that 50.1.0 update is available, and it has a link to view more info, which goes to https://www.mozilla.org/en-US/firefox/50.1.0/releasenotes/

But both https://www.mozilla.org/en-US/firefox/50.1.0/releasenotes/ and https://www.mozilla.org/en-US/firefox/new/  say "Congrats! You’re using the latest version of Firefox."

My firefox version is 50.0.2
Hi,

I retested this and in my case everything works as expected. On Mac OS X 10.10 with FF 50.0.2 and update to 50.1.0. I will reopen this and assigned to a component.
Status: RESOLVED → REOPENED
Component: Untriaged → Application Update
Ever confirmed: true
Product: Firefox → Toolkit
Resolution: INCOMPLETE → ---
Version: 35 Branch → 50 Branch
Application Update behaved correctly in offering the 50.1 update. The website does its own version checking.
Component: Application Update → General
Product: Toolkit → www.mozilla.org
Version: 50 Branch → Production
The page on mozilla.org currently only detects the major version number, since minor version are not exposed in the Firefox UA string by policy. We may change this in the future using a more privileged API on the mozorg page, so I'll leave this open for now.
Also note: that you can still download Firefox regardless to what the text in the top corner of the page says.

Comment 9

a year ago
My suggestion to fix this is to change it so that it warns you if you have an older major version number, And, if you have a current major version number, instead of saying congrats it would say nothing at all.

That way it's never wrong or misleading, and it achieves the goal of warning users of old version *as best as it is capable of doing* due to the UA string policy limitation.

Users should be using Help About instead anyway since it does know about minor version numbers. And automatic update users don't really need either thing.
(In reply to blud from comment #9)
> My suggestion to fix this is to change it so that it warns you if you have
> an older major version number, And, if you have a current major version
> number, instead of saying congrats it would say nothing at all.
> 
> That way it's never wrong or misleading, and it achieves the goal of warning
> users of old version *as best as it is capable of doing* due to the UA
> string policy limitation.
> 
> Users should be using Help About instead anyway since it does know about
> minor version numbers. And automatic update users don't really need either
> thing.

We already display a warning for users on an older major version number. Removing the up to date message would not totally fix the problem (e.g. being warned about an out-of-date minor version or chemspill release). Like I said, we may switch to using a more privileged API in the future.

Comment 11

a year ago
The reporter's only issues were
- that the Download link on the /releasenotes/ page went to https://www.mozilla.org/en-US/firefox/new/ instead of to a download of the latest version of firefox
- that https://www.mozilla.org/en-US/firefox/new/ incorrectly stated "Congrats! You’re using the latest version of Firefox."

And my only additional issue, in Comment 4, was that https://www.mozilla.org/en-US/firefox/50.1.0/releasenotes/ incorrectly showed "Congrats! You’re using the latest version of Firefox."


The reporter's first issue is currently fixed. If you go to the /releasenotes/ page, the Download link always takes you to the download of the latest version, it never takes you to https://www.mozilla.org/en-US/firefox/new/

My additional issue is also fixed now. If you go to the releasenotes page it no longer says "Congrats!". I guess they changed that in the last few days.

So the only outstanding issue in Bug 1125935 is that https://www.mozilla.org/en-US/firefox/new/ can incorrectly show "Congrats! You’re using the latest version of Firefox."

I understand that removing the up to date message would not fix every aspect of the overarching problem (and that it may get totally fixed with a future API), but it would fix Bug 1125935, because it would no longer incorrectly show "Congrats".
It's less than ideal if the page doesn't warn about out-of-date minor versions, but isn't it fully *bad* for the page to misinform the user with a false up-to-date message? It gives a green checkmark all clear even if the minor version is a security patch...
You need to log in before you can comment on or make changes to this bug.