Control click in selection box opens new tab

VERIFIED DUPLICATE of bug 120973

Status

SeaMonkey
Tabbed Browser
VERIFIED DUPLICATE of bug 120973
16 years ago
10 years ago

People

(Reporter: gbrinkmann, Assigned: jag (Peter Annema))

Tracking

Trunk
mozilla1.1alpha
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
I have turned on: "Middle-click or control-click of links in a web page" opens a
tab instead of windows. (i really like it)

To select two options in a selection-box you have to control-click the second
option. This opens a new tab, but should not. (Mozilla Version 0.9.6)
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 1

16 years ago
wfm/linux/2001112808

Comment 2

16 years ago
works for me/linux/build 2001112712.

gbrinkmann@dimedis.de - can you reproduce this on any page (with a list box), or
only on a special one? Can you provide exact steps how to reproduce this?
(Reporter)

Comment 3

16 years ago
Oh, sorry, i have only tested it on one page. This still does have this
phenomenon. In a normal case the control-click does work.

I have stripped down this page to a minimal example (will attach this after
submitting this text). 

The reason for the described behaviour is an anchor-tag 

  <a name="projects">

right before the select-box. It is not closed, so mozilla thinks of a clicked
a-href and opens up a new tab. If you remove it or close it with </a> the
select-box works fine.

I do not know if the unclosed tag is correct html, but i think it should be ok
as long as you do not use xhtml or xml.
(Reporter)

Comment 4

16 years ago
Created attachment 59710 [details]
example of open a-tag with control click of select-box opens a new tab

Updated

16 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.1

Comment 5

16 years ago
nice debugging. Technically an <a> is allowed to contained <select> (for what 
purpose I'm not sure). So, that the control click in that select bubbles up to 
the <a> isn't really wrong. 

What is perhaps wrong though is the "<a name="projects">a named anchor</a>"
by itself will open a new tab. It should probably only do this a for <a href>.

However, the case of <a name> around <select> is pretty rare :-]
(Reporter)

Comment 6

16 years ago
To be sure: The "a"-tag was not *around* the select-box but only *before* it
(but unclosed). But ok, i know how to "fix" the html-code. Ciao, Gert.

Comment 7

16 years ago
Au contraire. Until it is closed, it is open, and allowed to contain (among 
other things) form controls. Stick a 'a {border: 1px dotted red; padding: 2px}' 
in the example and you see that the form control is contained within the 
linebox of the <a name> [part of the form control juts outside of the linebox,
and I'd have to channel dbaron to explain why that is (probably) correct; there 
does seem to be a bug, in that a block element should implicity close the open
<a>, since block content is not supposed to be contained inside <a>, but it 
doesn't appear to close it out when I put a <div> into the example. 

But, anyways, it's a minor point, and you have the workaround for the fact that 
contained or not, control click on <a name> with no 'href' shouldn't be handled
as a link to an external page (since it isn't).

Comment 8

16 years ago
Reassigning to new component owner.
Assignee: hyatt → jaggernaut
Status: ASSIGNED → NEW
(Assignee)

Comment 9

16 years ago
Dupe of bug 120973, which has a fix.

*** This bug has been marked as a duplicate of 120973 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
v
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.