Closed Bug 1125990 Opened 5 years ago Closed 5 years ago

Repair simulator logging methods

Categories

(Firefox OS Graveyard :: Simulator, defect)

defect
Not set

Tracking

(firefox36 wontfix, firefox37 wontfix, firefox38 fixed, b2g-v2.2 fixed, b2g-master fixed)

RESOLVED FIXED
2.2 S5 (6feb)
Tracking Status
firefox36 --- wontfix
firefox37 --- wontfix
firefox38 --- fixed
b2g-v2.2 --- fixed
b2g-master --- fixed

People

(Reporter: jryans, Assigned: jryans)

References

Details

(Keywords: regression)

Attachments

(1 file)

After https://hg.mozilla.org/mozilla-central/rev/8132d858fefe from bug 1090949, the simulator stopped writing log messages.

This is because we switched to EventEmitter, which puts the name of the event as the first arg.
Depends on: 1116611
Attachment #8554766 - Flags: review?(poirot.alex)
Assignee: nobody → jryans
Status: NEW → ASSIGNED
Attachment #8554766 - Flags: review?(poirot.alex) → review+
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/3e1b33613ad8
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Comment on attachment 8554766 [details] [diff] [review]
Repair simulator logs and exit codes. r=ochameau

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 1090949
User impact if declined: Simulators will be harder to debug
Testing completed: Locally and on m-c
Risk to taking this patch (and alternatives if risky): Low, simulator only
String or UUID changes made by this patch: None
Attachment #8554766 - Flags: approval-mozilla-b2g37?
Attachment #8554766 - Flags: approval-mozilla-b2g37? → approval-mozilla-b2g37+
Depends on: 1132539
No longer depends on: 1132539
You need to log in before you can comment on or make changes to this bug.