Closed Bug 1126008 Opened 5 years ago Closed 5 years ago

IndexedDB UnknownErr: IDBDatabase.cpp:776

Categories

(Core :: Storage: IndexedDB, defect)

35 Branch
x86_64
Linux
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1083285

People

(Reporter: jdscheff, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:35.0) Gecko/20100101 Firefox/35.0
Build ID: 20150112203352

Steps to reproduce:

A user on my website http://play.basketball-gm.com/ reported seeing this error in Firefox:

    UnknownErr: IDBDatabase.cpp:776

My website is a game that will store a ridiculously large amount of data in IndexedDB if you play long enough, so the error is likely related to that. But I'd guess that you don't actually intend to be showing that error in the browser because it is not very helpful (not clear what it means and no documentation available). Instead, I'd be curious about under what circumstances that unhelpful error message can arise and what it means.

I found a few other bugs mentioning it, but they seem unrelated:

https://bugzilla.mozilla.org/show_bug.cgi?id=1118055
https://bugzilla.mozilla.org/show_bug.cgi?id=1093254
https://bugzilla.mozilla.org/show_bug.cgi?id=1090821


Actual results:

An incomprehensible error message.


Expected results:

Either no error or a more useful error message.
FWIW, this error just means that there was a transaction in flight when the user navigated or closed the page.  We made this more descriptive in bug 1083285 which is in Firefox 36.
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1083285
You need to log in before you can comment on or make changes to this bug.