Message lost because of poor UX design - "There was an error saving the message to Sent. Retry? (OK/Cancel)" lacks "save" choice.

RESOLVED DUPLICATE of bug 28211

Status

Thunderbird
Message Compose Window
--
critical
RESOLVED DUPLICATE of bug 28211
3 years ago
8 months ago

People

(Reporter: Christopher, Unassigned)

Tracking

31 Branch
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/40.0.2214.91 Safari/537.36

Steps to reproduce:

1) Write an E-mail
2) Send
3) A dialog says "There was an error saving the message to Sent. Retry? (OK/Cancel)" (could be a network problem)
4) Presses "Cancel"


Actual results:

The composer window closed and the message is lost forever (no copy in draft folder).


Expected results:

The composer window should be kept open so the user can continue editing the message, retry sending or close the window explicitly.

Reason : It's very common users want to take the chance to continue editing the message after the sending error.

OK retries sending, Cancel deletes the message.
At least, please add a third option for "Continue Editing", or change the "Cancel" button to leave the composer open.
But please avoid having users losing their messages because of a poor UX design.
(Reporter)

Updated

3 years ago
Severity: normal → critical
Priority: -- → P1

Comment 1

3 years ago
Thanks for reporting this. rather sure this is a duplicate of an existing bug report.
Priority: P1 → --
Summary: Message lost because of poor UX design → Message lost because of poor UX design - "There was an error saving the message to Sent. Retry? (OK/Cancel)" lacks "save" choice.
Whiteboard: [dupeme]

Comment 2

3 years ago
(In reply to Wayne Mery (:wsmwk) from comment #1)
> Thanks for reporting this. rather sure this is a duplicate of an existing
> bug report.

Indeed. I have raised bug 786868 from enhancement to critical due to the dataloss involved here.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Whiteboard: [dupeme]
Duplicate of bug: 786868
(Reporter)

Comment 3

3 years ago
Thanks Thomas.
I confirm I'm using IMAP too.

I lost another message today, because I accidentally pressed the ESC-key while the "Retry dialog" popped-up just some milliseconds in front of the window I was working on.
I'm glad I noticed the dialog appeared and closed at all, so I was able to at least rewrite the E-mail I lost.
I have to add that this happened to me before (pressing ESC key while working on another window and losing the message that was being sent in background).

Please add a "Continue Composing" option to this dialog and *also leave it as the default option* in case a user presses the ESC-key while working on other windows.

Best regards.

Comment 4

8 months ago
The messages are often actually sent. But no local copy is saved. So leaving the composer window open serves no use. I don't know how many emails I have no record of due to this "bug". Will it ever be fixed or should we start looking for alternative mail clients?
Duplicate of bug: 28211
You need to log in before you can comment on or make changes to this bug.