Closed Bug 1126083 Opened 7 years ago Closed 7 years ago

Do not search remote providers when in private browsing

Categories

(Firefox OS Graveyard :: Gaia::System::Browser Chrome, defect)

x86
macOS
defect
Not set
normal

Tracking

(b2g-v2.2 verified, b2g-master verified)

VERIFIED FIXED
2.2 S5 (6feb)
Tracking Status
b2g-v2.2 --- verified
b2g-master --- verified

People

(Reporter: kgrandon, Assigned: kgrandon)

References

Details

(Whiteboard: [systemsfe])

Attachments

(2 files)

One part we forgot to do was that we should probably not search remote providers for suggestions/web results when inside a private browsing window.
Comment on attachment 8554917 [details] [review]
[PullReq] KevinGrandon:bug_1126083_private_browser_remote_search to mozilla-b2g:master

This is the easiest way that I could think of doing this. Dale - could you review this?
Attachment #8554917 - Flags: review?(dale)
Comment on attachment 8554917 [details] [review]
[PullReq] KevinGrandon:bug_1126083_private_browser_remote_search to mozilla-b2g:master

Yeh I think that is the most reasonable implementation, looks good to me, cheers
Attachment #8554917 - Flags: review?(dale) → review+
Keywords: checkin-needed
Autolander could not locate a review from a user within the suggested reviewer list. Either the patch author or the reviewer should be in the suggested reviewer list.

Note: Until bug 1095028 lands, the patch *must* have a review by a suggested reviewer. If you are the patch author, you can leave an additional R+ on the attachment for autolander to process it.
Autolander could not locate a review from a user within the suggested reviewer list. Either the patch author or the reviewer should be in the suggested reviewer list.

Note: Until bug 1095028 lands, the patch *must* have a review by a suggested reviewer. If you are the patch author, you can leave an additional R+ on the attachment for autolander to process it.
Attachment #8554917 - Flags: review+
Keywords: checkin-needed
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Comment on attachment 8554917 [details] [review]
[PullReq] KevinGrandon:bug_1126083_private_browser_remote_search to mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Implementation.
[User impact] if declined: Users may not trust private browsing if they see auto-complete suggestions being returned in rocketbar. This is something that is not really spec'd until now. Desktop deals with this by having two search bars, but auto-complete does appear to work in the search bar. In chrome there is only a single urlbar, and auto-complete does not function.
[Testing completed]: Manual and unit testing.
[Risk to taking this patch] (and alternatives if risky): Fairly low risk, small-ish change only in rocketbar and search app.
[String changes made]: No.
Attachment #8554917 - Flags: approval-gaia-v2.2?(fabrice)
Attachment #8554917 - Flags: approval-gaia-v2.2?(fabrice) → approval-gaia-v2.2+
Whiteboard: [systemsfe]
This bug has been verified as pass on latest Nightly Flame v2.2 & master.

STR:
1.Launch browser app.
2.Tap 'New private window'.
3.Put in words in search bar.
Actual results: There is no auto-complete suggestion in private browsing.

See attachment: verified_Flame master.3gp
Reproduce rate: 0/6

Device: Flame 2.2 (Pass)
Build ID               20150721162504
Gaia Revision          e1e6317f17a840b19af9dbb25f5a771d8d9fa161
Gaia Date              2015-07-15 21:05:11
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/a73051740290
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150721.203051
Firmware Date          Tue Jul 21 20:31:03 EDT 2015
Bootloader             L1TC000118D0

Device: Flame master (Pass)
Build ID               20150721160205
Gaia Revision          84c3bf622e211046d905803b34de5d331761f22d
Gaia Date              2015-07-21 16:28:35
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/1875a5584e5f
Gecko Version          42.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150721.194129
Firmware Date          Tue Jul 21 19:41:42 EDT 2015
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
QA Whiteboard: [MGSEI-Triage+]
You need to log in before you can comment on or make changes to this bug.