Closed Bug 11261 Opened 22 years ago Closed 22 years ago

[Blocker]Profile Manager buttons not functioning properly...

Categories

(Core Graveyard :: Profile: BackEnd, defect, P3)

defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: jay, Assigned: vidur)

References

Details

The Profile Manager has a lot of buttons that do not function properly.

1. On Mac, if you delete the registry file and launch apprunner, you cannot
create a new file (or even continue with the default profile "mozProfile")
because the "Next" button does not do anything.

2. On Win98 and Linux (Profile Manager launched by using "apprunner
-ProfileManager"), the "New" button does not work, makind it impossible to
create a new profile.
These problems began with build 1999080408 on all 3 platforms
Assignee: selmer → gayatrib
Gayatri, on Bijal's machine we saw a javascript error at line 26 of
navigationStart.xul.
*** Bug 11264 has been marked as a duplicate of this bug. ***
*** Bug 11292 has been marked as a duplicate of this bug. ***
Summary: Profile Manager buttons not functioning properly... → [Blocker]Profile Manager buttons not functioning properly...
Ditto for NT.  Here's the javascript error:

Object must be of type NSLocation
URL: file:///Y|/mozilla/dist/WIN32_D.OBJ/bin/res/profile/navigationStart.xul
LineNo: 26

I can't do anything until this bug is fixed because I have already deleted my
moz directory.
Status: NEW → RESOLVED
Closed: 22 years ago
Resolution: --- → FIXED
Changed the syntax of location.replace to comply with the new syntax
location.href (seems to be the effect of Vidur's checkins yesterday)in all
relevant files. It works fine now. Marking it fixed.
Status: RESOLVED → VERIFIED
Verified Fixed with 08/05 builds.
Status: VERIFIED → REOPENED
As location.replace is widely used, it would probably be better to support it
also, along with location.href. Reopening the bug and assigning it to Vidur.
Assignee: gayatrib → vidur
Status: REOPENED → NEW
Resolution: FIXED → ---
*** Bug 11314 has been marked as a duplicate of this bug. ***
Status: NEW → RESOLVED
Closed: 22 years ago22 years ago
Resolution: --- → FIXED
Fix checked in on 8/5/1999. Both location.replace() and location.href can be
used, though the former does not add a new history entry for the new URL.
location.replace() was broken by my change yesterday, but has since been fixed.
Status: RESOLVED → VERIFIED
Component: Profile Manager → Profile Manager BackEnd
Moving all Profile Manager bugs to new Profile Manager Backend component.
Profile Manager component to be deleted.
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.