Intermittent test_authentication.js | Test timed out

RESOLVED DUPLICATE of bug 1055121

Status

()

RESOLVED DUPLICATE of bug 1055121
4 years ago
4 years ago

People

(Reporter: KWierso, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
16:12:25 INFO - TEST-PASS | netwerk/test/unit/test_assoc.js | took 4477ms
16:12:25 INFO - mozdevice getting files in '/mnt/sdcard/tests/xpcshell/minidumps'
16:12:28 INFO - TEST-START | netwerk/test/unit/test_auth_jar.js
16:12:30 INFO - TEST-PASS | netwerk/test/unit/test_auth_jar.js | took 1466ms
16:12:30 INFO - mozdevice getting files in '/mnt/sdcard/tests/xpcshell/minidumps'
16:12:32 INFO - TEST-START | netwerk/test/unit/test_auth_proxy.js
16:12:34 INFO - TEST-PASS | netwerk/test/unit/test_auth_proxy.js | took 2368ms
16:12:34 INFO - mozdevice getting files in '/mnt/sdcard/tests/xpcshell/minidumps'
16:12:36 INFO - TEST-START | netwerk/test/unit/test_authentication.js
16:17:36 WARNING - TEST-UNEXPECTED-TIMEOUT | netwerk/test/unit/test_authentication.js | Test timed out
16:17:36 INFO - TEST-INFO took 300000ms
16:17:36 INFO - mozdevice Could not connect; sleeping for 5 seconds.
16:17:36 INFO - Following exceptions were raised:
16:17:36 INFO - Traceback (most recent call last):
16:17:36 INFO - File "/builds/panda-0327/test/build/tests/xpcshell/runxpcshelltests.py", line 159, in run
16:17:36 INFO - self.run_test()
16:17:36 INFO - File "/builds/panda-0327/test/build/tests/xpcshell/runxpcshelltests.py", line 654, in run_test
16:17:36 INFO - stdout=self.pStdout, stderr=self.pStderr, env=self.env, cwd=test_dir, timeout=testTimeoutInterval)
16:17:36 INFO - File "/builds/panda-0327/test/build/tests/xpcshell/remotexpcshelltests.py", line 147, in launchProcess
16:17:36 INFO - self.device.killProcess(cmd[0])
16:17:36 INFO - File "/builds/panda-0327/test/build/venv/lib/python2.7/site-packages/mozdevice/devicemanagerSUT.py", line 562, in killProcess
16:17:36 INFO - if self.processExist(appname):
16:17:36 INFO - File "/builds/panda-0327/test/build/venv/lib/python2.7/site-packages/mozdevice/devicemanager.py", line 448, in processExist
16:17:36 INFO - processInfo = self.processInfo(processName)
16:17:36 INFO - File "/builds/panda-0327/test/build/venv/lib/python2.7/site-packages/mozdevice/devicemanager.py", line 433, in processInfo
16:17:36 INFO - procList = self.getProcessList()
16:17:36 INFO - File "/builds/panda-0327/test/build/venv/lib/python2.7/site-packages/mozdevice/devicemanagerSUT.py", line 447, in getProcessList
16:17:36 INFO - data = self._runCmds([{ 'cmd': 'ps' }])
16:17:36 INFO - File "/builds/panda-0327/test/build/venv/lib/python2.7/site-packages/mozdevice/devicemanagerSUT.py", line 151, in _runCmds
16:17:36 INFO - self._sendCmds(cmdlist, outputfile, timeout, retryLimit=retryLimit)
16:17:36 INFO - File "/builds/panda-0327/test/build/venv/lib/python2.7/site-packages/mozdevice/devicemanagerSUT.py", line 127, in _sendCmds
16:17:36 INFO - self._doCmds(cmdlist, outputfile, timeout)
16:17:36 INFO - File "/builds/panda-0327/test/build/venv/lib/python2.7/site-packages/mozdevice/devicemanagerSUT.py", line 237, in _doCmds
16:17:36 INFO - temp = self._sock.recv(1024)
16:17:36 INFO - AttributeError: 'NoneType' object has no attribute 'recv'
16:17:36 INFO - Traceback (most recent call last):
16:17:36 INFO - File "/builds/panda-0327/test/build/tests/xpcshell/remotexpcshelltests.py", line 628, in <module>
16:17:36 INFO - main()
16:17:36 INFO - File "/builds/panda-0327/test/build/tests/xpcshell/remotexpcshelltests.py", line 623, in main
16:17:36 INFO - **options.__dict__):
16:17:36 INFO - File "/builds/panda-0327/test/build/tests/xpcshell/runxpcshelltests.py", line 1375, in runTests
16:17:36 INFO - raise exceptions[0]
16:17:36 INFO - AttributeError: 'NoneType' object has no attribute 'recv'
16:17:36 ERROR - Return code: 1
16:17:36 ERROR - No tests run or test summary not found
16:17:36 INFO - Output logcat...
16:17:37 INFO - Connecting to: panda-0327
16:17:37 INFO - *** STARTING LOGCAT ***
16:17:37 INFO - --------- beginning of /dev/log/main
16:17:37 INFO -
Comment hidden (Treeherder Robot)
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Keywords: intermittent-failure
Resolution: --- → DUPLICATE
Duplicate of bug: 1055121
You need to log in before you can comment on or make changes to this bug.