Closed Bug 1126129 Opened 5 years ago Closed 5 years ago

Don't use SQLite tracing unless the right environment variable is set

Categories

(Toolkit :: Storage, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla38
Tracking Status
firefox35 --- wontfix
firefox36 --- fixed
firefox37 --- fixed
firefox38 --- fixed

People

(Reporter: bent.mozilla, Assigned: bent.mozilla)

References

Details

Attachments

(1 file)

Bug 806819 defined FORCE_PR_LOG everywhere, and the storage code then uses SQLite's tracing API regardless of whether or not the user wants to see those messages. This can slow us down significantly.
Duplicate of this bug: 1126130
(Pre-emptively reviewed since I have a patch on bug 531122 that does the same thing as part of a general logging cleanup.)
We should backport this as far as possible too...
Agreed, especially if this was one of the SQLite memory uses nnethercote tracked down as triggering pathologically bad memory allocation patterns by SQLite.
thank you for discovering and taking care of this.
https://hg.mozilla.org/mozilla-central/rev/9c28c90d3408
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla38
Comment on attachment 8554987 [details] [diff] [review]
Patch, v1

Approval Request Comment
[Feature/regressing bug #]: 806819
[User impact if declined]: Slower database access
[Describe test coverage new/current, TreeHerder]: I don't think there are any tests for PR_LOG code.
[Risks and why]: None - this simply stops us from asking SQLite to operate in a slower mode.
[String/UUID change made/needed]: None
Attachment #8554987 - Flags: approval-mozilla-beta?
Attachment #8554987 - Flags: approval-mozilla-aurora?
Attachment #8554987 - Flags: approval-mozilla-beta?
Attachment #8554987 - Flags: approval-mozilla-beta+
Attachment #8554987 - Flags: approval-mozilla-aurora?
Attachment #8554987 - Flags: approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.