Closed Bug 1126231 Opened 5 years ago Closed 5 years ago

[e10s] closing a browser window with tabs sharing the camera or microphone leaves the global sharing indicator visible

Categories

(Firefox :: Site Permissions, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1109087
Tracking Status
e10s m8+ ---

People

(Reporter: florian, Unassigned)

References

(Blocks 2 open bugs)

Details

I can reproduce only when e10s is enabled.

Steps to reproduce:
- go to https://apprtc.webrtc.org/ click "join" and share the devices.
- notice the global sharing indicator (it's in the menu bar on Mac).
- close the browser window

Actual result:
The green light of the camera turns itself off, but the global indicator icons remain in the menu bar. Clicking these icons results in the "JavaScript error: resource:///modules/webrtcUI.jsm, line 69: TypeError: browserWindow is null" JS error.

Expected result:
Closing the window should remove the global indicator.

I tested only on Mac, I don't know if this bug can be reproduced on other platforms.
Florian, are you going to take this?
tracking-e10s: --- → m8+
Flags: needinfo?(florian)
(In reply to Brad Lassey [:blassey] (use needinfo?) from comment #1)
> Florian, are you going to take this?

Unlikely in the 38 cycle. Later, I could if nobody beats me to it.
Flags: needinfo?(florian)
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1109087
You need to log in before you can comment on or make changes to this bug.