mail composition crash if scrolling through 6 or more adresses

VERIFIED DUPLICATE of bug 110165

Status

MailNews Core
Composition
--
critical
VERIFIED DUPLICATE of bug 110165
17 years ago
10 years ago

People

(Reporter: kuenne, Assigned: Jean-Francois Ducarroz)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

5.92 KB, application/octet-stream
Details
10.76 KB, application/octet-stream
Details
4.17 KB, application/octet-stream
Details
(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:0.9.6) Gecko/20011121
BuildID:    2001112115

Compose a new mail by starting "Compose" from the mail/news window. Add one
"To:" address and at least 5 "CC:" addresses (I couldn't reproduce it with 4).
Now a small scrollbar appears right from the addresses. Now grab the slider from
this scrollbar with the mouse and drag it quickly up and down several times (the
number of times you have to do it apparently depends on the speed of the
machine, I can crash mozilla quicker on my Ultra5 as on a E220R with faster
CPU's). After several movements of the slider mozilla crashes.

Reproducible: Always
Steps to Reproduce:
1.Compose a new mail message
2.Specify 6 or more addresses for the message
3.Scroll quickly through the addresses with the scrollbar

Actual Results:  mozilla crashes

Expected Results:  well, it shouldn't crash

I'm using the "modern" skin if that matters. I could reproduce the problem also
on my self-compiled mozilla but not on milestone 0.9.5.
The crash apparently appears in nsHTMLInputElement::SetValueSecure in
components/libgkcontent.so and it looks like some memory corruption. I'll try to
attach a stacktrace.
(Reporter)

Comment 1

17 years ago
Created attachment 59698 [details]
stacktrace from crash of build 2001112115
(Reporter)

Comment 2

17 years ago
Created attachment 59699 [details]
another stacktrace
(Reporter)

Comment 4

17 years ago
Created attachment 59700 [details]
and another stacktrace

*** This bug has been marked as a duplicate of 110165 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 6

16 years ago
verified dup
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.