If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Resolve issues building and running Heka on CentOS 7

RESOLVED FIXED

Status

Cloud Services
Metrics: Pipeline
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: mreid, Assigned: trink)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Branching off bug 1122754, there are some issues building and running heka on CentOS 7 (with CMake 2.8).

First, the resulting RPM will not install without a --force due to directory conflicts on /usr/bin

Once the rpm is force-installed, the `hekad` binary does not shut down gracefully on Ctrl+C. It just shuts down immediately without any cleanup.

Updated

3 years ago
Assignee: nobody → whd
Status: NEW → ASSIGNED

Comment 1

3 years ago
Here's the current output when you try to install a heka RPM created with "make package":

--> Running transaction check
---> Package heka.x86_64 0:0.9.0-1 will be installed
--> Processing Dependency: liblua.so()(64bit) for package: heka-0.9.0-1.x86_64
--> Processing Dependency: libluasandbox.so()(64bit) for package: heka-0.9.0-1.x86_64
--> Finished Dependency Resolution
Error: Package: heka-0.9.0-1.x86_64 (/heka-0_9_0-linux-amd64)
           Requires: libluasandbox.so()(64bit)
Error: Package: heka-0.9.0-1.x86_64 (/heka-0_9_0-linux-amd64)
           Requires: liblua.so()(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

I believe this is because RHEL and derivatives use /usr/lib64 for shared libraries on x86_64, and the RPM installs them to /usr/lib instead.

Can you take a look at this :trink? I tried replacing some references to lib with lib64 in heka cmake files and env.sh (to no avail). I'm guessing fixing this will require cmake changes to sub-projects like lua-sandbox. The location of arch-specific shared-libraries is probably distro-specific, so I'm not sure what the "correct" way of specifying this value is.

This is technically not specific to our data pipeline build so perhaps we should file a separate issue in heka's github tracker for this.
Flags: needinfo?(mtrinkala)

Comment 2

3 years ago
Created attachment 8559613 [details]
cpack_output.txt

Also of note, with check-rpaths enabled the rpmbuild fails with the attached output. I suspect this is expected behavior, but we might want to note that somewhere.
(Assignee)

Comment 3

3 years ago
It looks like the rpath needs some tweaking, I will have to take a look can you point me to your build system.
Assignee: whd → mtrinkala
Flags: needinfo?(mtrinkala)

Comment 4

3 years ago
:trink ec2-54-191-156-19.us-west-2.compute.amazonaws.com in your home directory. I just ran the same build on CentOS 6 and it installs without issue, which is interesting.
(Assignee)

Comment 5

3 years ago
Closed via https://github.com/mozilla-services/heka/pull/1330
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Reporter)

Comment 6

3 years ago
I tested again and could not reproduce the "immediate shutdown on sigint" problem.
You need to log in before you can comment on or make changes to this bug.