[RTL] The duration of a call doesn't display correctly in Call information

VERIFIED WORKSFORME

Status

Mozilla Localizations
ar / Arabic
P1
normal
VERIFIED WORKSFORME
3 years ago
3 years ago

People

(Reporter: jlorenzo, Unassigned)

Tracking

unspecified
x86_64
Linux
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(feature-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [2.2-bug-bash])

Attachments

(3 attachments)

(Reporter)

Description

3 years ago
Created attachment 8555334 [details]
Screenshot

Prerequisites:
Have a couple of phone calls that lasted more than 1 minute.

STR
1. Go to call log
2. Select a call and go to call information

Expected results
Per Ahmed Nefzaoui, a duration should be displayed like:
> s 5 m 2
> Of course with changing s & m to their Arabic equivalents.

Actual results
You see m 2 s 5. See attached screenshot
(Reporter)

Comment 1

3 years ago
Can we add this bug as a 2.2 feature?
Flags: needinfo?(doliver)
(Reporter)

Updated

3 years ago
QA Whiteboard: [rtl-impact]
(Reporter)

Comment 2

3 years ago
See comment 1.
Flags: needinfo?(doliver) → needinfo?(whuang)
triage: need to fix the ordering of the time units
feature-b2g: --- → 2.2+
Priority: -- → P1
Flags: needinfo?(whuang)
Ahmed, we're missing the string "callDurationTextFormatHours" in the dialer.ar.properties file, which seems to be the cause of this. Could you add this and check if it works?

Delphine, I'm needinfoing you just to get this on the radar for an Arabic community member to translate this (if not Ahmed).
Component: Gaia::Dialer → Gaia::L10n
Flags: needinfo?(nefzaoui)
Flags: needinfo?(lebedel.delphine)
Thanks Doug, adding Rami in CC so he's aware and can get to this when he has some time
thanks!
Flags: needinfo?(lebedel.delphine)
Flags: in-moztrap+
Doesn't seem like a l10n.js. Moving to Arabic component for now, if there's nothing that localization can do it should be moved to a more appropriate component in Firefox OS.
Component: Gaia::L10n → ar / Arabic
Product: Firefox OS → Mozilla Localizations

Comment 7

3 years ago
Hi Francisco,
Do you know who can take this bug? Thanks!
Flags: needinfo?(francesco.lodolo)
It will be managed by localizers. Has someone checked this again recently? Because it seems fixed as far as I can tell (Jan 29)
http://hg.mozilla.org/gaia-l10n/ar/rev/a245116e4743

P.S. I'm Italian, not Spanish ;-)
Flags: needinfo?(francesco.lodolo)
Hi Francesco, 

I've just tested with current gaia (master 6/02/2014) and gecko and I can't even see the time on the left side in the call log (in english or in arabic). Is it something normal?
Flags: needinfo?(francesco.lodolo)
Created attachment 8560462 [details]
Screenshots 3.0

It works for me (need to long tap and view the detail of an item in the call log)
Flags: needinfo?(francesco.lodolo)
Agreed, this appears to be fixed on master at least. Johan, can you take another look on 2.2?
Flags: needinfo?(nefzaoui) → needinfo?(jlorenzo)
(Reporter)

Comment 12

3 years ago
Created attachment 8560710 [details]
1 min 4 sec call log on 2.2 with Arabic - Screenshot

Looks fixed to me on the latest 2.2:
Gaia-Rev        a52999ce7f783177deb17e267bf003a53e6fde06
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/01446d5231ef
Build-ID        20150206002505
Version         37.0a2
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150206.035621
FW-Date         Fri Feb  6 03:56:32 EST 2015
Bootloader      L1TC000118D0
Flags: needinfo?(jlorenzo)
(Reporter)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-b2g-v2.2: affected → verified
status-b2g-master: affected → verified
Resolution: --- → WORKSFORME
(Reporter)

Updated

3 years ago
Status: RESOLVED → VERIFIED
 Test case has been added in moztrap:
https://moztrap.mozilla.org/manage/case/15434/
You need to log in before you can comment on or make changes to this bug.