Crash when scrolling in FxOS twitter app

RESOLVED WORKSFORME

Status

defect
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: sfoster, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 affected)

Details

Attachments

(4 attachments)

On my Flame, 319MB, running trunk, STR: 
Install Twitter app from Marketplace on nightly b2g/gaia
Scroll down several screens of posts 

I was able to crash 3/3 times. The crash didn't seem to correlate with loading more data. I've attached logcat output.

I'm guessing at the component, please redirect if necessary.
Reporter

Comment 1

4 years ago
Another logcat, should be 2 crashes in there?
Can you provide also dmesg log? It could be get like the following.

> adb shell dmesg > dmesg_log.txt


From the following, there could be a possibility that the app is killed by low memory.
------------------------------------------

I/GonkMemoryPressure( 1858): Checking to see if memory pressure is over.
I/GonkMemoryPressure( 1858): Memory pressure is over.
I/GonkMemoryPressure(32056): Checking to see if memory pressure is over.
I/GonkMemoryPressure(32056): Memory pressure is over.
Flags: needinfo?(sfoster)
Reporter

Comment 3

4 years ago
Posted file dmesg_log.txt
Here's the dmesg output. In each case I think the only other app I had running was Clock. The phone has been running since yesterday, last reboot maybe 18 hours before.
Flags: needinfo?(sfoster)
In attachment 8555367 [details], there is following log. It says that twitter app is killed by low memory killer.

-------------------------------------------------------------

<6>[48227.511808] Killing 'Twitter' (21250), adj 134,
<6>[48227.511813]    to free 35488kB on behalf of 'Twitter' (21250) because
<6>[48227.511817]    cache 6096kB is below limit 6144kB for oom_score_adj 117
<6>[48227.511822]    Free memory is 1376kB above reserved.
<6>[48227.511825]    Free CMA is 756kB
<6>[48227.511828]    Total reserve is 2908kB
<6>[48227.511831]    Total free pages is 2132kB
<6>[48227.511834]    Total file cache is 8040kB
<6>[48227.511837]    GFP mask is 0x213d2
Sam, can you confirm that the problem happens also on b2g v2.2?
Flags: needinfo?(sfoster)
Reporter

Comment 6

4 years ago
Freshly flashed 2.2, 219MB memory, I was able to reproduce - though it took a while and I had to keep scrolling for a few minutes.
Flags: needinfo?(sfoster)
blocking-b2g: --- → 2.2?
Thanks for the confirmation.

Updated

4 years ago
blocking-b2g: 2.2? → 2.2+
I'm not sure this is actionable as a graphics bug.
Component: Graphics → General
Product: Core → Firefox OS
Whiteboard: [gfx-noted]
Version: Trunk → unspecified

Comment 9

4 years ago
qawanted for branch check
Keywords: qawanted
I could easily reproduce the crash on the earlier build:

Device: Flame 3.0 (KK, 319mb, full flash)
Build ID: 20150127010228
Gaia: b02ec9713e6de8d96c6954d2c0dfd0442b0656ac
Gecko: 38e4719e71af
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0


However, after trying about 30 times, I've never encountered any crash while scrolling Twitter app on today's Flame Master and 2.2.

Device: Flame Master (KK, 319mb, full flash)
Build ID: 20150305010212
Gaia: eff3321ab4e65da3f906688ebb55ddf1e93d9452
Gecko: 56492f7244a9
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 39.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Device: Flame 2.2 (KK, 319mb, full flash)
Build ID: 20150305002528
Gaia: 89af288bad6751248ff84504fa898206fee127fe
Gecko: 6d8d294aa8f3
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: qawanted
[:YeojinC] thanks your effort on this. I'll close this as works-for-me, as I'm also unable to reproduce anymore. We did have some major graphics patches land this week, perhaps they fixed this?
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WORKSFORME
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.