Don't show the navigation arrows for the screenshots if all of them are visible on the details page

VERIFIED FIXED

Status

P3
normal
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: krupa.mozbugs, Assigned: spasovski)

Tracking

x86
Gonk (Firefox OS)
Points:
---

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8555499 [details]
navigation arrows.png

steps to reproduce:
1. Load https://marketplace-dev.allizom.org/app/book-note?src=branded-editorial-element
2. Notice the preview screenshot section

expected behavior:
Since there are only two screenshots listed, there are no navigation arrows


actual behavior:
Navigation arrows are present for just two screenshots and are redundant.
This bug would appear to actually be that, when there are fewer than 3 screenshots, the preview tray should show the first one as current and the second one to the right, rather than the second one as current and the first one to the left.
Priority: -- → P3
(Assignee)

Updated

4 years ago
Assignee: nobody → dspasovski
(Assignee)

Comment 2

4 years ago
https://github.com/mozilla/fireplace/commit/88bf48f

The desktop detail screenshots previews will now start with the first one "centered" when less than 3 previews exist. A good app to test this with is: https://marketplace-dev.allizom.org/app/slice-fruits
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Reporter)

Comment 3

4 years ago
verified fixed at https://marketplace-dev.allizom.org/app/book-note?src=branded-editorial-element
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.