Closed Bug 1126653 Opened 6 years ago Closed 6 years ago

don't send nfc-manager-tech-lost if the foreground has received ontag/peerfound.

Categories

(Firefox OS Graveyard :: NFC, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(firefox36 wontfix, firefox37 wontfix, firefox38 fixed, b2g-v2.2 fixed, b2g-master fixed)

RESOLVED FIXED
2.2 S5 (6feb)
Tracking Status
firefox36 --- wontfix
firefox37 --- wontfix
firefox38 --- fixed
b2g-v2.2 --- fixed
b2g-master --- fixed

People

(Reporter: allstars.chh, Assigned: allstars.chh)

References

Details

(Whiteboard: [p=1])

Attachments

(1 file, 1 obsolete file)

This is a follow-up in Bug 1082443.
In Bug 1082443 we broadcast nfc-manager-tech-discovered when app cannot handle this. But if the app could handle the event, when the tag/peer is removed, we still send nfc-manager-tech-lost to System app, which is inconsistent.

We should also prevent sending nfc-manager-tech-lost if the app has received ontag/peerfound before.
Attached patch Patch. (obsolete) — Splinter Review
Attachment #8555633 - Flags: review?(dlee)
Attached patch Patch. v2Splinter Review
Attachment #8555633 - Attachment is obsolete: true
Attachment #8555633 - Flags: review?(dlee)
Attachment #8555650 - Flags: review?(dlee) → review+
Comment on attachment 8555650 [details] [diff] [review]
Patch. v2

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
Bug 1082443

User impact if declined: 
Phone will still vibrate even the foreground app has processed NFC event.

Testing completed: 
Manually.

Risk to taking this patch (and alternatives if risky): 
No.

String or UUID changes made by this patch:
Update uuid in nsINfcContentHelper.idl, which is an internal IDL.
Attachment #8555650 - Flags: approval-mozilla-b2g37?
https://hg.mozilla.org/mozilla-central/rev/147167067e99
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Attachment #8555650 - Flags: approval-mozilla-b2g37? → approval-mozilla-b2g37+
You need to log in before you can comment on or make changes to this bug.