If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Test failure 'Update dialog wizard doesn't show 'Update XML file malformed (200)' error. - 'errors' should not equal 'errors'' in restartTests/testSoftwareUpdateAutoProxy/test2.js

RESOLVED WONTFIX

Status

Mozilla QA
Mozmill Tests
P3
normal
RESOLVED WONTFIX
3 years ago
2 years ago

People

(Reporter: Daniela Domnici, Unassigned)

Tracking

Version 3
x86_64
All

Firefox Tracking Flags

(firefox36 affected, firefox37 affected, firefox38 affected)

Details

(Whiteboard: [mozmill-test-failure], URL)

(Reporter)

Description

3 years ago
Module:   testSoftwareUpdateAutoProxy
Test  :   /restartTests/testSoftwareUpdateAutoProxy/test2.js
Error :   Update dialog wizard doesn't show 'Update XML file malformed (200)' error. - 'errors' should not equal 'errors'

Branch:   Beta
Platform: Win 5.1.2600

Reports: http://mozmill-release.blargon7.com/#/functional/failure?app=Firefox&branch=All&platform=All&from=2015-01-26&to=2015-01-28&test=%2FrestartTests%2FtestSoftwareUpdateAutoProxy%2Ftest2.js&func=testSoftwareUpdateAutoProxy
(Reporter)

Updated

3 years ago
status-firefox36: --- → affected
Whiteboard: [mozmill-test-failure]
Failed with aurora and nightly too over the weekend, all platforms:
http://mozmill-daily.blargon7.com/#/functional/failure?app=Firefox&branch=All&platform=All&from=2015-01-31&to=2015-02-02&test=%2FrestartTests%2FtestSoftwareUpdateAutoProxy%2Ftest2.js&func=testSoftwareUpdateAutoProxy
status-firefox37: --- → affected
status-firefox38: --- → affected
OS: Linux → All
Priority: -- → P3
First of all this test is remote not functional, then I can reproduce this only if I disable the internet connection. Judging the fact that all the failures were at the same time, I think it was a network glitch.

Henrik, in bug 599290 comment 94 you said that this test is about to be removed, is that still the case? Otherwise I suggest we refactor this test to a single-file restart test and move it under remote suite.
Flags: needinfo?(hskupin)
We are not going to fix mozmill-test failures anymore. Also this test is no longer needed due to changes of the application update code. Closing as Wontfix.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(hskupin)
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.