mp3 audio streaming start is delayed [intermittent]

RESOLVED FIXED in Firefox 36

Status

()

defect
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: adalucinet, Assigned: bholley)

Tracking

(Blocks 1 bug)

38 Branch
mozilla38
x86
macOS
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox36 fixed, firefox37 fixed, firefox38 fixed)

Details

Attachments

(3 attachments)

logged as requested in bug 1121148 comment 17

Reproducible on Nightly 38.0a1 (Build ID: 20150127030230) *only* with e10s enabled
Platform: Mac OS X 10.10

Steps to reproduce:
1. Navigate to http://radiobattletoads.com/test_mozilla.php
2. Click on Play radio (mp3) button

Expected results: Audio starts in 1, 2 seconds.

Actual results: Audio is delayed.
Posted file log
Flags: needinfo?(bobbyholley)
Thanks for the bug report. Looks like this affects the media code in general (not just Nightly), and it's just an issue of e10s altering the timing and getting us to go into buffering mode before we finish prerolling.

I reproduced those conditions artificially, and found a number of bugs. I'll work up some patches.
Assignee: nobody → bobbyholley
Flags: needinfo?(bobbyholley)
Blocks: 1132554
The apple MP3 decoder passes in garbage for this particular live stream. Let's
validate our inputs.
Attachment #8563521 - Flags: review?(cpearce)
GetEstimatedBufferedTimeRanges returns an empty range if the duration is -1.
Attachment #8563522 - Flags: review?(cpearce)
Attachment #8563522 - Flags: review?(cpearce) → review+
Attachment #8563521 - Flags: review?(cpearce) → review+
Comment on attachment 8563522 [details] [diff] [review]
Part 2 - Bail out of HasLowUndecodedData if we don't have a duration. v1

Flagging for aurora/beta approval. Not sure if it's too late for beta - if it is it's probably ok. This is basically the same regression as bug 1121148, but more intermittent. We've only seen this in practice with e10s, because it's very timing dependent.

Approval Request Comment
[Feature/regressing bug #]:bug 1091008
[User impact if declined]: potential 30-second delay when buffering a video
[Describe test coverage new/current, TreeHerder]: None
[Risks and why]: Low. But given where we are in the cycle, that still might be too much for beta.
[String/UUID change made/needed]: None
Attachment #8563522 - Flags: approval-mozilla-beta?
Attachment #8563522 - Flags: approval-mozilla-aurora?
Comment on attachment 8563522 [details] [diff] [review]
Part 2 - Bail out of HasLowUndecodedData if we don't have a duration. v1

We are going to build a beta 10. Not sure that we will take it or not right now.
Anyway, we probably want that in aurora.
Attachment #8563522 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/mozilla-central/rev/20a6417016df
https://hg.mozilla.org/mozilla-central/rev/16df4e462d80
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla38
Comment on attachment 8563522 [details] [diff] [review]
Part 2 - Bail out of HasLowUndecodedData if we don't have a duration. v1

Taking it in beta 10 too. We will be able to backout this change in the RC build if it creates regressions.
Attachment #8563522 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Comment on attachment 8563522 [details] [diff] [review]
Part 2 - Bail out of HasLowUndecodedData if we don't have a duration. v1

Oh, e10s specific. Not taking it.
Attachment #8563522 - Flags: approval-mozilla-beta+ → approval-mozilla-beta-
(In reply to Sylvestre Ledru [:sylvestre] from comment #11)
> Comment on attachment 8563522 [details] [diff] [review]
> Part 2 - Bail out of HasLowUndecodedData if we don't have a duration. v1
> 
> Oh, e10s specific. Not taking it.

The reporter was only able to reproduce the issue with e10s, but the actual bug could happen for any other reason that changes timing (i.e. network traffic patterns).
Flags: needinfo?(sledru)
Comment on attachment 8563522 [details] [diff] [review]
Part 2 - Bail out of HasLowUndecodedData if we don't have a duration. v1

OK
Flags: needinfo?(sledru)
Attachment #8563522 - Flags: approval-mozilla-beta- → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.