Check for updates (via About Firefox) fails silently

RESOLVED DUPLICATE of bug 679742

Status

()

Toolkit
Application Update
RESOLVED DUPLICATE of bug 679742
3 years ago
3 years ago

People

(Reporter: Joe Magura, Unassigned)

Tracking

34 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/39.0.2171.95 Safari/537.36

Steps to reproduce:

With a proxy in place implementing a white list from which mozilla.org and mozilla.net are excluded (i.e. the proxy will block attempts to access these URLs) and Firefox set to use the proxy (in my case via "use system settings" but likely irrelevant what the mechanism is), using the "About Firefox" about box to check for updates indicates no updates are available.


Actual results:

A check from Firefox on another, proxyless, system clearly indicates an update from 34.X to 35.X is available.  I.e. Firefox is failing to determine the actual availability of updates and is not reporting the lack of access to mozilla.org.

Note: If I add mozilla.org to the white list (i.e. allow navigation to that URL), I am informed that an update is available but, since mozilla.net is still blocked I see the message "Update failed.  Download the latest version."  This is desired behavior since it makes it clear a problem has occurred and provides a workaround.


Expected results:

I would think Firefox should report lack of connectivity, when mozilla.org cannot be reached and queried  rather than make a misleading statement that no updates are available!  The casual user is left thinking all is well, when in fact they have a serious configuration problem.

Updated

3 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Component: Untriaged → Application Update
Product: Firefox → Toolkit
Resolution: --- → DUPLICATE
See Also: → bug 701733
Duplicate of bug: 1017817

Updated

3 years ago
Duplicate of bug: 679742
You need to log in before you can comment on or make changes to this bug.