Flash enabled pages make plugin-container.exe to start, die, start again, die, and so on.

RESOLVED WORKSFORME

Status

()

Core
Plug-ins
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: diassuncao, Unassigned)

Tracking

35 Branch
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8555910 [details]
dying_plugin-container.png

User Agent: Mozilla/5.0 (Windows NT 6.0; rv:35.0) Gecko/20100101 Firefox/35.0
Build ID: 20150122214805

Steps to reproduce:

Open a Flash enabled page.
Flash is up to date (16.0.0.235).
Firefox is up to date (35.0.1).
Java is up to date (v8u31 b1.8.0_31-b13).
Windows vista is up to date.


Actual results:

Firefox window cursor blinks betwen arrow and hourglass(circle for vista)
plugin-container.exe start, die, start again, die, and so on.
plugin-container.exe does not launch flash plugin.
Flash enabled content does not play.


Expected results:

plugin-container.exe starts
plugin-container.exe launches flash plugin.
Flash enabled content plays.
(Reporter)

Comment 1

3 years ago
The problem seems to be associated to blocked flash content.

Comment 2

3 years ago
Seems to be isolated to each Firefox release channel. Initially broke for standard Firefox, then Nightly, then Beta and most recently Aurora/DE (for me). Broke for standard after an update, Nightly and Beta after closing and then reopening browser and broke for Aurora while watching a flash video.

Object still remains (black box for youtube, white box for content on Adobe Flash Player about page), still recognised by Adblock.
Component: Untriaged → Plug-ins
Product: Firefox → Core

Comment 3

3 years ago
dlassuncao, I'm sorry it took so long to get back to you about this report! If you're still seeing this, I have some questions:

* Are there any crash reports in about:crashes? If so please link to the crash report URL.
* What website(s) are you visiting? In general we should only be launching that plugin-container when the site loads a new Flash element, so if you just stay on a normal single page it might crash once and just wait.
Flags: needinfo?(diassuncao)
(Reporter)

Comment 4

3 years ago
Hi Benjamin!

It's been some time since I posted this bug report. Since then Firefox, java, flash and other softwares are not the same anymore. Also I can't really remember what exactly are the sites visited, i believe it happened to all flash-enabled sites. In this scenario, it become difficult to replicate the bug, and I have no bug report dated from near 2015-01-28 (older one date from 2015-05-29). At the end, as the bug is not showing itself in this Firefox version (42.0) i think its reasonable to close this case.

Still, if you need any information,  I am at your services.

Thank you for your attention.
Flags: needinfo?(diassuncao)

Comment 5

3 years ago
Thanks. We've been doing active work in plugins, as has Adobe, so I'm glad to know that this is mostly-better.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.