If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

test zip packages include .pyc files

RESOLVED FIXED in Firefox 38

Status

Testing
General
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: catlee, Assigned: catlee)

Tracking

unspecified
mozilla38
x86_64
Linux
Points:
---

Firefox Tracking Flags

(firefox38 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

3 years ago
The tests.zip packages include .pyc files for jetpack:

     2824  01-26-2015 13:49   jetpack/python-lib/simplejson/scanner.pyc
    13242  01-26-2015 13:49   jetpack/python-lib/simplejson/encoder.pyc
    12283  01-26-2015 13:49   jetpack/python-lib/simplejson/decoder.pyc
    14140  01-26-2015 13:49   jetpack/python-lib/simplejson/__init__.pyc
    17566  01-26-2015 13:49   jetpack/python-lib/cuddlefish/packaging.pyc
     8495  01-26-2015 13:49   jetpack/python-lib/cuddlefish/rdf.pyc
     1076  01-26-2015 13:49   jetpack/python-lib/cuddlefish/util.pyc
     3541  01-26-2015 13:49   jetpack/python-lib/cuddlefish/property_parser.pyc
     5389  01-26-2015 13:49   jetpack/python-lib/cuddlefish/_version.pyc
    27771  01-26-2015 13:49   jetpack/python-lib/cuddlefish/manifest.pyc
     4924  01-26-2015 13:49   jetpack/python-lib/cuddlefish/xpi.pyc
    26538  01-26-2015 13:49   jetpack/python-lib/cuddlefish/__init__.pyc
     1874  01-26-2015 13:49   jetpack/python-lib/cuddlefish/preflight.pyc
     1790  01-26-2015 13:49   jetpack/python-lib/cuddlefish/bunch.pyc

These probably aren't needed since the .py files are also included in the zip.
(Assignee)

Comment 1

3 years ago
The problem is here:
http://hg.mozilla.org/mozilla-central/file/1daa622bbe42/addon-sdk/Makefile.in#l40

we copy in all of python-lib into the tests staging area, which includes .pyc files.
(Assignee)

Comment 2

3 years ago
Created attachment 8559942 [details] [diff] [review]
nopyc-mozilla-central.patch

the find command isn't following the symlink from dist/test-stage/.../lib into the source directory, where the .pyc files actually live.
Attachment #8559942 - Flags: review?(ted)
Comment on attachment 8559942 [details] [diff] [review]
nopyc-mozilla-central.patch

Review of attachment 8559942 [details] [diff] [review]:
-----------------------------------------------------------------

As I said on IRC, it might be simpler to just use -x *.pyc in the zip command, but I also wrote the original find command here so who am I to argue with myself?
Attachment #8559942 - Flags: review?(ted) → review+
https://hg.mozilla.org/mozilla-central/rev/6d1ab7695d2b
Assignee: nobody → catlee
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox38: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla38
You need to log in before you can comment on or make changes to this bug.