Closed Bug 112702 Opened 19 years ago Closed 15 years ago

Screenshot handler (Save Page As... Image)

Categories

(SeaMonkey :: General, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 113231

People

(Reporter: liorean, Unassigned)

Details

(Keywords: helpwanted)

Attachments

(1 file)

This is probably not anything that should go to Mozilla, but to someone
producing sidebars, but since I know of no such persons I'll file it here anyways.

I'd like an interface, a sidebar feature, a menubar/context menu feature or
whatever, that has the ability to take customised screenshots of Mozilla:
(Saw something similar to this feature in Amiga OS)

- Capture whole document as if it was rendered in as wide and high window as
necessary. (Strip all chrome, only content)
- Capture the window in the size it is currently (preferably by short-key so
that you don't have to have a sidebar or such that takes up space you might want
the window to have availible)
- Capture the content as it would look in default chrome setup on various
resolutions (640x480, 800x600, 1024x768, etc.) to see how it might look if you
have another config and resolution than currently.
- Chose path and file format for the screenshot file (.jpeg, .png, .bmp are
probably the best choices)
- Capture all mozilla windows as displayed currently, including chrome, but
leave non-mozilla parts of the screen out of the screenshot (good for themes,
since you then would be able to open all the different mozilla features and take
one screenshot of the entire thing)
- Chose whether chrome should be included or not for the screenshot
- Take screenshots of all tabs in curent window

Most interesting of this is - I think - is if we could get a whole-document
screenshot feature (like what I hear exists on Mac platform) built into the
browser, so that you don't have to take multiple screenshots and merge them.
Keywords: helpwanted
in windows, alt-printscreen will capture the active window. printscreen 
captures the entire screen. you can paste the capture into any app.

Printing a document to a file (eg postscript or pdf or [macosx] display pdf) is 
handled by printer drivers. On windows you can install a postscript printer 
driver and select print to file.  Some of the other points are interesting, but 
i don't think mozilla needs any of them.
confirming to get off the unco radar
Status: UNCONFIRMED → NEW
Ever confirmed: true
Hyperionics's HyperSnap-DX utility (http://www.hyperionics.com) on Win can make
screenshots of whole documents with Mozilla, so somebody could debug, what
events HyperSnap is sending to Mozilla (but this is possible workaround). 
Does exist rendered page as bitmap?

Timeless: IMHO this feature could be in Mozilla in future, because it is usefull
for webdevelopers and newswriters.

Plat: PC -> All, OS: W2K -> All
OS: Windows 2000 → All
Hardware: PC → All
Timeless, the feature I want most, is not to capture a regular screenshot as
displayed on screen. That I can get easily enough through windows interface. No,
I want a feature that captures the entire document, as if it was in a window so
big that you didn't have to scroll.

Then I'd like to be able to save that without using a graphics editor. Think
about those poor web developers that are on a computer in a cyber café for
instance, lacking all graphics handling programs. They'd maybe still want to be
able to save a screenshot to a file, to mail it for instance.
another time-sink for web developers is showing how a layout looks at various
resolutions in various sized-windows (to convince someone that they don't really
want the layout they think they want). The initial RFE description inculded this
sort of thing as a possible direction to go with this feature.

It'd be swell if this sort of thing could be made easier.
probably  belongs at mozdev or  something.
Assignee: asa → nobody
In bug 220763 is idea of saving page as image. IMHO perfect GUI for this feature.
Summary: [RFE] Screenshot handler → Screenshot handler
Summary: Screenshot handler → Screenshot handler (Save Page As... Image)
Asides from a thread recently posted on orkut
(http://www.orkut.com/CommMsgs.aspx?cmm=2710&tid=12 - title : html2jpg
extension) has any progress been made on this recently?
Maybe Crystalzilla should provide some ideas about taking a bitmap:
http://interreality.org/wwwvos/projects/crystalzilla
Product: Browser → Seamonkey
Duplicate of/related to bug 113231 (via bug 173756 and bug 235944)?
Rob: I have to assume you intended to attach that elsewhere

dupe of "converting print request to image capture"

*** This bug has been marked as a duplicate of 113231 ***
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
My apologies on the attachment. I meant to be attaching to bug 293925 and somehow got here! The attachment doesn't belong to this bug.
You need to log in before you can comment on or make changes to this bug.