cannot write to frames in new window

RESOLVED WORKSFORME

Status

()

--
major
RESOLVED WORKSFORME
17 years ago
17 years ago

People

(Reporter: ssotton, Assigned: jst)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.4)
Gecko/20011019 Netscape6/6.2
BuildID:    6.2

This page works properly in IE5-6, NS4 and Opera 5-6.  When the Pharos link at
the bottom of the page is clicked, a new window should pop up and be populated
with two frames which initially display "Please Wait".  This part works in NS6.
 After the Please wait, the individual frames should be populated; the top frame
with a button, and the bottom frame with the opening page for Pharos.  This does
not happen.  There is a javascript error saying that "NewWindow.document.F1 has
no properties".  F1 is the name of the top frame.  NS6 either doesn't recognize
the frames or doesn't think they have properties.


Reproducible: Always
Steps to Reproduce:
1.open page
2.click on Pharos link
3.check the Javascript console

Actual Results:  frames fail to populate

Expected Results:  frames should populate with button on top and web page on bottom

works perfectly in IE 5-6, NS4, Opera 5-6
Which link is the "Pharos" link exactly?

Comment 2

17 years ago
Reporter could you please tell us where the Pharos link is? We can't find it on
the page mentionned in the URL field above. Also you may want to try with a
nightly build instead of NS6.2 to see if we have fixed it since then.
Thanks in advance.
(Reporter)

Comment 3

17 years ago
It seems I made a mistake on the URL.  The URl of the test page should be:

http://www.calstatela.edu/library/bi/ssotton/unioncat2ns6.html

Apologies.

Steve
Ok.  Worksforme with a current nightly, but this could be a timing issue, I
guess...
(Reporter)

Comment 5

17 years ago
Boris' comment seems to indicate that the problem has been solved in a later
build.  Will there be a release version soon?
(Assignee)

Comment 6

17 years ago
WORKSFORME too.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.