Intermittent zero-ratio-no-dimensions-cover.html | application crashed [@ mozilla::layers::GetDrawTargetForDescriptor(mozilla::layers::SurfaceDescriptor const&, mozilla::gfx::BackendType)]

RESOLVED DUPLICATE of bug 1127391

Status

()

RESOLVED DUPLICATE of bug 1127391
4 years ago
4 years ago

People

(Reporter: RyanVM, Unassigned)

Tracking

Trunk
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
11:24:23 INFO - REFTEST TEST-START | http://10.26.133.20:30561/tests/layout/reftests/backgrounds/vector/empty/zero-ratio-no-dimensions-cover.html
11:24:23 INFO - REFTEST TEST-LOAD | http://10.26.133.20:30561/tests/layout/reftests/backgrounds/vector/empty/zero-ratio-no-dimensions-cover.html | 1552 / 1781 (87%)
11:24:23 INFO - INFO | automation.py | Application ran for: 0:19:45.545167
11:24:23 INFO - INFO | zombiecheck | Reading PID log: /tmp/tmp66Jii1pidlog
11:24:23 INFO - Contents of /data/anr/traces.txt:
11:24:26 INFO - mozcrash INFO | Downloading symbols from: https://ftp-ssl.mozilla.org/pub/mozilla.org/mobile/tinderbox-builds/mozilla-inbound-android-api-11/1422469837/fennec-38.0a1.en-US.android-arm.crashreporter-symbols.zip
11:24:31 INFO - mozcrash INFO | Saved minidump as /builds/panda-0561/test/build/blobber_upload_dir/4c96ee00-41bb-22e1-5c76a740-2c52a9c1.dmp
11:24:31 INFO - mozcrash INFO | Saved app info as /builds/panda-0561/test/build/blobber_upload_dir/4c96ee00-41bb-22e1-5c76a740-2c52a9c1.extra
11:24:31 WARNING - PROCESS-CRASH | http://10.26.133.20:30561/tests/layout/reftests/backgrounds/vector/empty/zero-ratio-no-dimensions-cover.html | application crashed [@ mozilla::layers::GetDrawTargetForDescriptor(mozilla::layers::SurfaceDescriptor const&, mozilla::gfx::BackendType)]
11:24:31 INFO - Crash dump filename: /tmp/tmpTYcMxl/4c96ee00-41bb-22e1-5c76a740-2c52a9c1.dmp
11:24:31 INFO - Operating system: Android
11:24:31 INFO - 0.0.0 Linux 3.2.0+ #2 SMP PREEMPT Thu Nov 29 08:06:57 EST 2012 armv7l pandaboard/pandaboard/pandaboard:4.0.4/IMM76I/5:eng/test-keys
11:24:31 INFO - CPU: arm
11:24:31 INFO - 2 CPUs
11:24:31 INFO - Crash reason: SIGSEGV
11:24:31 INFO - Crash address: 0x1b
11:24:31 INFO - Thread 46 (crashed)
11:24:31 INFO - 0 libxul.so!mozilla::layers::GetDrawTargetForDescriptor(mozilla::layers::SurfaceDescriptor const&, mozilla::gfx::BackendType) [ISurfaceAllocator.cpp:ad37c88b6aed : 68 + 0x0]
11:24:31 INFO - r4 = 0x6d7ffc7c r5 = 0x00000000 r6 = 0x6dc30c00 r7 = 0x00000000
11:24:31 INFO - r8 = 0x00000000 r9 = 0x00000000 r10 = 0x00100000 fp = 0x00000001
11:24:31 INFO - sp = 0x6d7ffc6c lr = 0x636b0c65 pc = 0x636a799c
11:24:31 INFO - Found by: given as instruction pointer in context
11:24:31 INFO - 1 libxul.so!mozilla::layers::CompositorParent::RecvMakeSnapshot(mozilla::layers::SurfaceDescriptor const&, nsIntRect const&) [CompositorParent.cpp:ad37c88b6aed : 562 + 0x3]
11:24:31 INFO - r4 = 0x6d7ffc80 r5 = 0x00000000 r6 = 0x6dc30c00 r7 = 0x00000000
11:24:31 INFO - r8 = 0x00000000 r9 = 0x00000000 r10 = 0x00100000 fp = 0x00000001
11:24:31 INFO - sp = 0x6d7ffc78 pc = 0x636b0c65
11:24:31 INFO - Found by: call frame info
11:24:31 INFO - 2 0x6e03109e
11:24:31 INFO - r4 = 0x7eabefec r5 = 0x00000153 r6 = 0x6d279000 r7 = 0x00000000
11:24:31 INFO - r8 = 0x00000000 r9 = 0x00000000 r10 = 0x00100000 fp = 0x00000001
11:24:31 INFO - sp = 0x6d7ffc90 pc = 0x6e0310a0
11:24:31 INFO - Found by: call frame info
11:24:31 INFO - 3 libxul.so!RunnableMethod<SoftwareDisplay, void (SoftwareDisplay::*)(mozilla::TimeStamp), Tuple1<mozilla::TimeStamp> >::Run() [tuple.h:ad37c88b6aed : 393 + 0x17]
11:24:31 INFO - sp = 0x6d7ffce8 pc = 0x636a5cdd
11:24:31 INFO - Found by: stack scanning
11:24:31 INFO - 4 libxul.so!MessageLoop::RunTask(Task*) [message_loop.cc:ad37c88b6aed : 361 + 0x5]
11:24:31 INFO - r4 = 0x6c4fbc80 sp = 0x6d7ffcf8 pc = 0x6347ed89
11:24:31 INFO - Found by: call frame info
11:24:31 INFO - 5 libxul.so!MessageLoop::DeferOrRunPendingTask(MessageLoop::PendingTask const&) [message_loop.cc:ad37c88b6aed : 369 + 0x5]
11:24:31 INFO - r4 = 0x00000001 r5 = 0x6d7ffdf8 sp = 0x6d7ffd08 pc = 0x63481251
11:24:31 INFO - Found by: call frame info
11:24:31 INFO - 6 libxul.so!MessageLoop::DoDelayedWork(base::TimeTicks*) [message_loop.cc:ad37c88b6aed : 474 + 0x3]
11:24:31 INFO - r4 = 0x6d262390 r5 = 0x6d7ffdf8 sp = 0x6d7ffd18 pc = 0x634814f7
11:24:31 INFO - Found by: call frame info
11:24:31 INFO - 7 libxul.so!base::MessagePumpDefault::Run(base::MessagePump::Delegate*) [message_pump_default.cc:ad37c88b6aed : 39 + 0xb]
11:24:31 INFO - r4 = 0x6d262380 r5 = 0x6d7ffdf8 r6 = 0x00000000 r7 = 0x6468f1ab
11:24:31 INFO - r8 = 0x6468f1ab r9 = 0x6d5eca90 sp = 0x6d7ffd98 pc = 0x6347ee6d
11:24:31 INFO - Found by: call frame info
Comment hidden (Treeherder Robot)
(Reporter)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Keywords: crash, intermittent-failure
Resolution: --- → DUPLICATE
Duplicate of bug: 1127391
You need to log in before you can comment on or make changes to this bug.