Firefox spellcheck on Facebook comment forms doesn't wait until words are completed

RESOLVED WORKSFORME

Status

()

Core
Spelling checker
RESOLVED WORKSFORME
3 years ago
a year ago

People

(Reporter: ihummel, Unassigned)

Tracking

35 Branch
x86_64
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:35.0) Gecko/20100101 Firefox/35.0
Build ID: 20150125222008

Steps to reproduce:

Typed text into a www.facebook.com comment form.


Actual results:

As I typed, each character was underlined red until the word was completed after which the underlining disappeared (if the word was spelled correctly).


Expected results:

The word should have only been underlined red once it was completed (as indicated by a space or punctuation mark denoting the ending of the word) and found to be misspelled (as is the case with other forms, such as the www.facebook.com post form).
(Reporter)

Updated

3 years ago
OS: Linux → All

Comment 1

3 years ago
This is happening to me as well in this comment box right here.

As I type the word "isn't", the red underline shows up right when I hit the apostrophe, even though I am typing quite quickly.   In the past, the misspelled word indicator didn't show up until after I hit the space bar to indicate I was done typing the word.

However, I think it is happening more often on Facebook than here at mozilla.

Comment 2

2 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:46.0) Gecko/20100101 Firefox/46.0
Nightly 46.0a1 Build ID:20160104030217

Ihummel,Thank you for taking time to report this.

In my case the spelling check waits until I press the space bar. Are you still getting the same issue in the latest version ? Have you tried with a fresh install ?
Component: Untriaged → Spelling checker
Flags: needinfo?(ihummel)
Product: Firefox → Core

Comment 3

2 years ago
Closing this as Works for me. Please feel free to reopen this bug if the issue still reproduces in the latest versions. Thanks
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME

Updated

a year ago
Flags: needinfo?(ihummel)
You need to log in before you can comment on or make changes to this bug.