OpenTokRTC.com no longer works with FF 37 or 38

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
4 years ago
3 years ago

People

(Reporter: mreavy, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

OpenTokRTC.com was broken by something in FF 37 and 38; it works with 35 & 36.

Per Byron, first bad nightly is Dec 30th, and it appears what's causing the problem is the patch for bug 1052610.  Likely this is a problem with their MCU.

Comment 1

4 years ago
In case of FF 37 the problem is with the DTLS establishment.    

Firefox 37 offers less cipher suites during the negotiation (only supporting DH and ECDH) and the MCU is not able to establish the connection with those ones.

Is that an intended change or is it going to be rolled back?   We have a patch for our server but AFAIK we don't plan to redeploy it soon.

Comment 2

4 years ago
Is this issue resolved by the fix for: https://bugzilla.mozilla.org/show_bug.cgi?id=1052610?
I believe the contrary. It's that code that broke it.

Comment 4

4 years ago
Thanks Eric. I understand now. As ggb mentioned, Tokbox has a media router patch that we are testing now to fix this in OpenTok.

Comment 5

4 years ago
I think this is fixed -- Mark, can you double-check that we need no more follow-up, and close this if you agree?
Component: WebRTC: Networking → General
Flags: needinfo?(standard8)
Product: Core → Loop
As far as I can tell, there's no more follow-up needed here. OpenTok is working, and our stats were reasonable last I checked ;-)
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(standard8)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.