If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Always Not close correctly, always not complete close, not close on close

RESOLVED WORKSFORME

Status

()

Firefox
Untriaged
RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: Wellington Torrejais da Silva, Unassigned)

Tracking

38 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8556291 [details]
close_problem.png

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:38.0) Gecko/20100101 Firefox/38.0
Build ID: 20150128101733

Steps to reproduce:

On normal browser close after navigate on normal pages for example:

-- https://bitly.com/shorten/

or

-- http://goo.gl/ALQ0yL


Actual results:

Attachment, alert on re-open the browser, browser not close on close 


Expected results:

Normal and fast close whiteout alerts and problems.
(Reporter)

Comment 1

3 years ago
Created attachment 8556292 [details]
normal-page-access
I'm suspecting this is also caused by one of your addons.
Please try in safe mode/new profile.
See Also: → bug 1127184
(Reporter)

Comment 3

3 years ago
(In reply to Paul Silaghi, QA [:pauly] from comment #2)
> I'm suspecting this is also caused by one of your addons.
> Please try in safe mode/new profile.

Yes problem occurred on new and clean installation too. But This problem not occurred on this time on last update, but pages stay loading forever and other minor bugs submitted on: http://input.mozilla.org/ because is more simple...
Mistakenly filed against Firefox 38 and should be instead 38 Branch. Sorry for the spam. dkl
Version: Firefox 38 → 38 Branch
Hi Wellington,

I have tested your issue on latest Firefox release (43.0.3) and latest Nightly (46.0a1) and I could not reproduce it. I accessed the links you've posted and the browser worked properly, no alerts or problems occurred when I closed or reopened the browser. 

Firefox: 46.0a1, Build ID: 20151223140742, User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:43.0) Gecko/20100101 Firefox/43.0
Firefox: 46.0a1, Build ID: 20160103030302, User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:46.0) Gecko/20100101 Firefox/46.0

Can you please test this on the latest Firefox release (43.0.3) or latest Nightly (46.0a1, https://nightly.mozilla.org/) and tell me if this still reproduces for you ? When doing this please use a new fresh Firefox profile, maybe also in safe mode (https://support.mozilla.org/en-US/kb/troubleshoot-and-diagnose-firefox-problems). Sometimes this kind of issues could appear when using custom settings, themes or some addons. 

Thanks,
Cosmin
Flags: needinfo?(wtds.trabalho)
(Reporter)

Comment 6

2 years ago
(In reply to Cosmin Muntean from comment #5)
> Hi Wellington,
> 
> I have tested your issue on latest Firefox release (43.0.3) and latest
> Nightly (46.0a1) and I could not reproduce it. I accessed the links you've
> posted and the browser worked properly, no alerts or problems occurred when
> I closed or reopened the browser. 
> 
> Firefox: 46.0a1, Build ID: 20151223140742, User Agent: Mozilla/5.0 (Windows
> NT 6.1; WOW64; rv:43.0) Gecko/20100101 Firefox/43.0
> Firefox: 46.0a1, Build ID: 20160103030302, User Agent: Mozilla/5.0 (Windows
> NT 6.1; Win64; x64; rv:46.0) Gecko/20100101 Firefox/46.0
> 
> Can you please test this on the latest Firefox release (43.0.3) or latest
> Nightly (46.0a1, https://nightly.mozilla.org/) and tell me if this still
> reproduces for you ? When doing this please use a new fresh Firefox profile,
> maybe also in safe mode
> (https://support.mozilla.org/en-US/kb/troubleshoot-and-diagnose-firefox-
> problems). Sometimes this kind of issues could appear when using custom
> settings, themes or some addons. 
> 
> Thanks,
> Cosmin

The origin of the issue is the E10S, but only on some minimum config pc. Thank for your help. Please close this bug report.
Flags: needinfo?(wtds.trabalho)
Hi Wellington,

Thanks for the reply. Considering comment #6 I will mark this as RESOLVED - WORKSFORME.

Thanks,
Cosmin.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.