Closed Bug 1127251 Opened 6 years ago Closed 6 years ago

[Woodduck][Contacts]Launching Contact will take more than 16 s after you restart device.

Categories

(Firefox OS Graveyard :: Gaia::Contacts, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(b2g-v2.0M affected)

RESOLVED WORKSFORME
Tracking Status
b2g-v2.0M --- affected

People

(Reporter: zikui.yang, Unassigned)

References

Details

(Keywords: perf)

Attachments

(1 file)

6.08 MB, video/mp4
Details
[1.Description]:
[Woodduck][v2.0][Contacts]Import 200 contacts to device,restart device,then launch the contact. It will take more than 5 ms to load the contact list, and take more than10 ms to load the contact photos.
Please refer to video:"001.MP4"

[2.Testing Steps]: 
Precondition:1.Import 200 contact to device by making reference-workload-light(some contacts with photo)
                     2.Turn off logger
Step:
1. Restart  device

2. Manually tap "Contacts" icon on the homescreen to launch contacts app. 

3. Measure the cold launch. The time from tapping Contact app till all contacts are loaded


[3.Expected Result]: 
3.Launching contact should take less than 6m.

[4.Actual Result]: 
3.Launch contact will take more than 16m.

[5.Reproduction build]: 
Woodduck 2.0M build:
Gaia-Rev        53526a3a5c913efc851b35e3d083cadf93cf8bef
Gecko-Rev       8f003ce490529003a774b260a4668deebed34ebb
Build-ID        20150128050313
Version         32.0

[6.Reproduction Frequency]: 
Always Recurrence,10/10

[7.TCID]: 15318
Attached video 001.mp4
Hi, Elie,

Do you mean "...  more than 16 seconds"?
Flags: needinfo?(zikui.yang)
(In reply to William Hsu [:whsu] from comment #2)
> Hi, Elie,
> 
> Do you mean "...  more than 16 seconds"?

Yes More than 16
Flags: needinfo?(zikui.yang)
Summary: [Woodduck][Contacts]Launching Contact will take more than 16ms after you restart device. → [Woodduck][Contacts]Launching Contact will take more than 16 s after you restart device.
(In reply to Elie from comment #3)
> (In reply to William Hsu [:whsu] from comment #2)
> > Hi, Elie,
> > 
> > Do you mean "...  more than 16 seconds"?
> 
> Yes More than 16s
 Update the Description
[1.Description]:
[Woodduck][v2.0][Contacts]Import 200 contacts to device,restart device,then launch the contact. It will take more than 5 seconds to load the contact list, and take more than 10 seconds to load the contact photos.
Please refer to video:"001.MP4"
[3.Expected Result]: 
3.Launching contact should take less than 6 seconds.

[4.Actual Result]: 
3.Launch contact will take more than 16 seconds.
Flags: needinfo?(whsu)
(In reply to Elie from comment #4)
> (In reply to Elie from comment #3)
> > (In reply to William Hsu [:whsu] from comment #2)
> > > Hi, Elie,
> > > 
> > > Do you mean "...  more than 16 seconds"?
> > 
> > Yes More than 16s
>  Update the Description
> [1.Description]:
> [Woodduck][v2.0][Contacts]Import 200 contacts to device,restart device,then
> launch the contact. It will take more than 5 seconds to load the contact
> list, and take more than 10 seconds to load the contact photos.
> Please refer to video:"001.MP4"
> [3.Expected Result]: 
> 3.Launching contact should take less than 6 seconds.
> 
> [4.Actual Result]: 
> 3.Launch contact will take more than 16 seconds.

Got it! Thanks for your confirmation.
Flags: needinfo?(whsu)
Hi, Josh,

This bug seems to be happen on woodduck v2.0M-ENG build.
woodduck v2.0M-USER build didn't have this problem.
Do we need to request for help or we just take a note of this?

What do you think?
Many thanks!
Flags: needinfo?(jocheng)
I think we can close this performance bug if it does not happen on user build. And We can reopen on partner request.
Keywords: perf
Blocks: Woodduck
Flags: needinfo?(jocheng)
This issue does not exist on Wooduck 2.0m
It will take about 6~9s to launch contact.
Rate:0/5
Build ID               20150302050313
Gaia Revision          a1b5959728c8bc2a82354e197bb161922d419866
Gaia Date              2015-02-13 09:00:02
Gecko Revision         d9b299dc1087f23c83321b4dccc92e0f52309e8e
Gecko Version          32.0
Device Name            jrdhz72_w_ff
Firmware(Release)      4.4.2
Firmware(Incremental)  1425243887
Firmware Date          Mon Mar  2 05:05:08 CST 2015
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.