Firefox for Android hangs with the Vellamo Benchmark

RESOLVED WORKSFORME

Status

()

Firefox for Android
General
--
critical
RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: enrico.ros, Unassigned)

Tracking

({hang})

35 Branch
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8556384 [details]
Screenshot_2015-01-29-01-56-42.png

User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/40.0.2214.85 Safari/537.36
Firefox for Android

Steps to reproduce:

To reproduce the issue:
 - install Firefox 35+ and Vellamo 3.1+ from the Play Store
 - close every tab from Firefox, including Firefox Home
 - open the Apps Stack and swipe away Firefox (needs to be a fresh start)
 - launch Vellamo -> select Firefox from the Browser card -> Run
 ~~ here Firefox stops with a blank screen

Note: if Firefox was already open or running in the background, it would work.

Vellamo starts the browser with an Intent containing the URL to load (served from localhost).



Actual results:

Firefox UI does not correctly start up. See the attachment. You can see that Firefox is started (e.g. the rounded tab on the top), but nothing else appears - not the benchmark or any error page.

If Firefox is then started from the App Launcher it will crash.

Repeating the process, with Firefox already open in background, will produce the correct execution of the benchmark.

The problem may be in the way that Intents are handled in Firefox when there is an overlay on the screen?


Expected results:

The Vellamo benchmark should have been loaded, executed and completed like it happens on other browsers.

Vellamo (http://goo.gl/HuaF3) automates browser benchmarking by feeding the browser with challenging web pages and observing the responses.
(Reporter)

Updated

3 years ago
OS: Linux → Android
Hardware: x86_64 → ARM

Updated

3 years ago
Severity: normal → critical
Component: Untriaged → General
Keywords: hang
Product: Firefox → Firefox for Android
Version: 35 Branch → Firefox 35
Works for me using Firefox 46 Nightly and the current Vellamo on the Play Store. Testing on a Nexus 5x.

Comment 2

2 years ago
It works for me using Firefox 47 Nightly and the current Vellamo 3.2 on the Play Store. Testing on a Galaxy S6
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.