Closed Bug 1127288 Opened 9 years ago Closed 9 years ago
Have headers in in-content prefs for both the DRM checkbox and the popup controls under Preferences -> Content
In-content prefs are usually grouped with headers. In bug 1111146, I removed the "Pop-ups" header so that I could group that checkbox with the one I added rather than introducing a "DRM Content" header. Having one header per checkbox doesn't really seem useful to me, so I think we'd rather have no header here or a "General" header for both checkboxes (like we do in the Security pane). If we end up not reinstating the "Pop-ups" header, that string should be removed from content.dtd.
I feel that the headers are important to have as it makes it easier for users to quickly scan a page to find what they want. Without the headers on some prefs users will be pulled out of "quick-scan mode" and they will be forced to read the details. Also, when search is implemented in about:preferences the headers will be nice to have in surfaced results.
Assignee: nobody → gijskruitbosch+bugs
Iteration: --- → 38.2 - 9 Feb
Points: --- → 2
Per comment #1
Status: NEW → ASSIGNED
Summary: Figure out whether popup blocking and DRM checkboxe under Preferences -> Content need a header → Have headers in in-content prefs for both the DRM checkbox and the popup controls under Preferences -> Content
I took the opportunity to fix the alignment of the 'learn more' link (it was 4px out compared to the buttons horizontally, and it was aligned differently in the row than the checkbox text meaning it was off vertically).
Attachment #8557460 - Flags: review?(dolske)
Comment on attachment 8557460 [details] [diff] [review] add header for DRM checkbox, fix link alignment, Review of attachment 8557460 [details] [diff] [review]: ----------------------------------------------------------------- ::: browser/locales/en-US/chrome/browser/preferences/content.dtd @@ +42,5 @@ > --> > <!ENTITY translation.options.attribution.beforeLogo "Translations by"> > <!ENTITY translation.options.attribution.afterLogo ""> > > +<!ENTITY drmContent.label "DRM content"> I feel like this must run afoul of some regulation from the Department of Redundancy Department... A "DRM content" label in the "content" tabs of prefs for a "play DRM content" pref. But I don't have a better suggestion. (Just "DRM" crossed my mind, but then we've got a weird / jargony 3-character header.)
Attachment #8557460 - Flags: review?(dolske) → review+
Inclusive of the redundancy inclusive*: remote: https://hg.mozilla.org/integration/fx-team/rev/1c1df7f43de0 * I'm sorry, I'm not as good at this as you are.
- (2015-03-05) (Fx37) https://hg.mozilla.org/releases/mozilla-beta/rev/4d6e9e4e5e87
You need to log in before you can comment on or make changes to this bug.