Mozregression may ask users to upgrade

RESOLVED FIXED

Status

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: parkouss, Assigned: hrudayranjansahoo0208, Mentored)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [good first bug][lang=python])

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
The idea comes from here: Bug 1122073 comment 2. Generally I don't really like tools that ask for upgrade, but it may be useful here.

I found an easy way to do this: https://wiki.python.org/moin/PyPIJSON. The idea is to get the following url http://pypi.python.org/pypi/mozregression/json, get the current version and compare it with the one in the package.

This may be done at startup. William, what do you think ? Do you like the idea ?
Alternative just throwing in a warning like:
A new version is out. Try installing it with: pip install -U mozregression
(Reporter)

Comment 2

4 years ago
I don't think this is an alternative - we need to have a way to compare installed version with the latest one on pypi. But that's a possible warning message.
Yup, I like this idea. Might make a good first bug if you want to mentor it?
(Reporter)

Comment 4

4 years ago
Sure! :)
Mentor: j.parkouss
Whiteboard: [good first bug][lang=python]
:julien i would really like to work on this bug .I m new to open source and i think this can help me to further venture in open source world.
(Reporter)

Comment 6

4 years ago
Hi Vaibhav,

Sure, you're welcome. :)

You can start by having a look at some places if you don't know them yet:

- http://mozilla.github.io/mozregression/documentation/usage.html (to have an idea of what mozregression is)
- https://github.com/mozilla/mozregression (github repo that you will need to fork)
- https://wiki.mozilla.org/Auto-tools/Projects/Mozregression (this will help you getting started with the code)

I assign you this bug. Do not hesitate to ask if you have some questions.
Assignee: nobody → choudharyvaibhav132
julien ,so what we have to do is every time we run mozregression it should check latest version from pypi(info.version in json object from pypi) compare it with its own and if new version is out it should display a message in command line that "A new version is out. Try installing it with: pip install -U mozregression".
(Reporter)

Comment 8

4 years ago
(In reply to vaibhav [:vaibhavChoudhary] from comment #7)
> julien ,so what we have to do is every time we run mozregression it should
> check latest version from pypi(info.version in json object from pypi)
> compare it with its own and if new version is out it should display a
> message in command line that "A new version is out. Try installing it with:
> pip install -U mozregression".

Hm actually I think we should include the new version number in this case. Pip for example write the following messages:

You are using pip version 6.0.3, however version 6.0.6 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.

I think we can use the same two lines (with a log.warning call for each). Other than this, what you said is exactly what we want. :)
Hey Hey!
Are you still working on this bug Vaibhav, 
If not, I would love to take this up as my first contribution to mozregression!
Flags: needinfo?(choudharyvaibhav132)
(Reporter)

Comment 10

4 years ago
Hello,

Yep, I would like this feature to be implemented. :) Let's wait for an answer of Vaibhav to see if he's still interested/have the time to work on this. I would say that if we have no answer one week after you asked him, you can work on this. (2015-02-24)

There is a link that can be used as an example for this issue: https://github.com/parkouss/subscope/blob/a4336e4eb04f7b8eeb25b76895dfbea95351f689/subscope/main.py#L127
(Assignee)

Comment 11

4 years ago
Hello,

I am actually new to open source and want to get some experience in contributing to mozilla codebase. If either Vaibhav or Prabhjyot have not started working on this, then is it possible that I can start working on this bug too?
(Reporter)

Comment 12

4 years ago
Hello!

Right, let's ask Prabhjyot as he asked first. :)
Flags: needinfo?(prabhjyotsingh95)
Hey
I really wanted to get started with mozregression with this, but looks like I won't have a lot of time in the coming 3 days.
Maybe Hrudata could take this!
Julien, Do you have some good first bug in mind for me? :)
Flags: needinfo?(prabhjyotsingh95)
(Reporter)

Comment 14

4 years ago
(In reply to Prabhjyot Sodhi [:psd] from comment #13)
> Hey
> I really wanted to get started with mozregression with this, but looks like
> I won't have a lot of time in the coming 3 days.
> Maybe Hrudata could take this!

Thanks for your fast answer! Ok then, I assign the bug to Hrudaya.

> Julien, Do you have some good first bug in mind for me? :)

Hmm, I will think about it, and let you know about that. Not sure for mozregression, I will ask around :)

@Hrudata
Let me know if you have any question; you can get started with what I wrote in comment 6, and by reading the comments on the bug to understand what needs to be done.

I'm clearing the request for Vaibhav.
Assignee: choudharyvaibhav132 → hrudayranjansahoo0208
Flags: needinfo?(choudharyvaibhav132)
(Assignee)

Comment 15

4 years ago
(In reply to Julien Pagès from comment #14)
> (In reply to Prabhjyot Sodhi [:psd] from comment #13)
> > Hey
> > I really wanted to get started with mozregression with this, but looks like
> > I won't have a lot of time in the coming 3 days.
> > Maybe Hrudata could take this!
> 
> Thanks for your fast answer! Ok then, I assign the bug to Hrudaya.
> 
> > Julien, Do you have some good first bug in mind for me? :)
> 
> Hmm, I will think about it, and let you know about that. Not sure for
> mozregression, I will ask around :)
> 
> @Hrudata
> Let me know if you have any question; you can get started with what I wrote
> in comment 6, and by reading the comments on the bug to understand what
> needs to be done.
> 
> I'm clearing the request for Vaibhav.

Thanks! :)
(Assignee)

Comment 16

4 years ago
Created attachment 8571337 [details] [review]
Added the code that asks mozregression for an upgrade and created a pull request on github
(Reporter)

Comment 17

4 years ago
Hi Hrudata,

Thanks for the PR!

Unfortunately you need to rebase your changes (you fork is no more synchronized with the current mozregression master branch). I added a comment to help you do that in the github PR. Ping me on irc if you have issues. :)
(Assignee)

Updated

4 years ago
Attachment #8571337 - Flags: review?(j.parkouss)
(Reporter)

Updated

4 years ago
Attachment #8571337 - Flags: review?(j.parkouss) → review+
(Reporter)

Comment 18

4 years ago
Thanks! This is merged in master. :)
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.