[Calendar] Changing system date doesn't update current date in Calendar app

RESOLVED DUPLICATE of bug 1118850

Status

RESOLVED DUPLICATE of bug 1118850
4 years ago
4 years ago

People

(Reporter: tedders1, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Steps to reproduce:

1) Open the calendar app.
2) Switch to 'Month' view.
3) Select a date other than the current date.
4) Note that the current date has a border around it.
5) Note that the current date appears on the button in the lower-left corner of the screen. (Tapping this button selects the current date.)
6) Open the Settings app.
7) Change the system date to a different date.
8) Return to the settings app.

Expected Result:
1) The new system date has a border around it.
2) The new system date appears on the button in the lower-left corner

Actual Result:
1) The former system date still has a border around it.
2) The former system date appears on the button in the lower-left corner

Note that tapping the button in the lower-left corner selects the *new* system date, even though the button is labelled with the *old* system date. This is a bit confusing.


Build: Master
Low pri qawanted: please check to see what happens after a reboot of the system.  If it still shows the former system date, we may want to take a look further.
Keywords: qawanted
Created attachment 8571142 [details]
video

Hi Ted Clancy,
This problem cannot be repro on latest build of Flame3.0(319mb). In step8: when I return to the Calendar app, the "File not found" prompt message page will be shown (It seems like the bug 1093841), relaunch Calendar app again, the current date will display correctly.
According to video, could you please help to confirm the issue repro steps, thanks!
See attachments: Video_1127536.MP4

Flame 3.0 build:
Build ID               20150301010223
Gaia Revision          f34ce82a840ad3c0aed3bfff18517b3f6a0eb37f
Gaia Date              2015-02-27 15:48:31
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/eea6188b9b05
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150301.045059
Firmware Date          Sun Mar  1 04:51:10 EST 2015
Bootloader             L1TC000118D0
Flags: needinfo?(tclancy)
QA Whiteboard: [MGSEI-Triage+]
Keywords: qawanted
(Reporter)

Comment 3

4 years ago
I assume this has been fixed by some other patch. It was probably a duplicate of something.

Feel free to resolve this as WORKSFORME.
Flags: needinfo?(tclancy)
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
this bug is hard to reproduce but I'm almost sure it still exists. marking as a duplicate of Bug 1118850 since I have an idea on how to solve it and going to work on this soon.
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 1118850
You need to log in before you can comment on or make changes to this bug.