Closed Bug 1127584 Opened 7 years ago Closed 6 years ago

Intermittent optimized_test.js | GAIA_OPTIMIZE=1 make with GAIA_OPTIMIZE=1 BUILD_DEBUG=1

Categories

(Firefox OS Graveyard :: Gaia::Build, defect)

x86_64
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1188585

People

(Reporter: KWierso, Assigned: gduan)

References

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

14:32:52 INFO - TEST-START | build/test/integration/multilocale_test.js | Multilocale integration tests make with absolute l10n path
14:34:25 INFO - TEST-PASS | build/test/integration/multilocale_test.js | Multilocale integration tests make with absolute l10n path
14:34:25 INFO - TEST-END | build/test/integration/multilocale_test.js | Multilocale integration tests make with absolute l10n path took 92919 ms
14:34:27 INFO - TEST-START | build/test/integration/multilocale_test.js | Multilocale integration tests make with relative l10n path but without concat
14:35:55 INFO - TEST-PASS | build/test/integration/multilocale_test.js | Multilocale integration tests make with relative l10n path but without concat
14:35:55 INFO - TEST-END | build/test/integration/multilocale_test.js | Multilocale integration tests make with relative l10n path but without concat took 87872 ms
14:35:56 INFO - TEST-START | build/test/integration/multilocale_test.js | Multilocale integration tests make with absolute l10n path but without concat
14:37:23 INFO - TEST-PASS | build/test/integration/multilocale_test.js | Multilocale integration tests make with absolute l10n path but without concat
14:37:23 INFO - TEST-END | build/test/integration/multilocale_test.js | Multilocale integration tests make with absolute l10n path but without concat took 87462 ms
14:37:25 INFO - TEST-START | build/test/integration/optimized_test.js | GAIA_OPTIMIZE=1 make with GAIA_OPTIMIZE=1 BUILD_DEBUG=1
14:42:25 INFO - TEST-UNEXPECTED-FAIL | build/test/integration/optimized_test.js | GAIA_OPTIMIZE=1 make with GAIA_OPTIMIZE=1 BUILD_DEBUG=1
14:42:25 INFO - Error: timeout of 300000ms exceeded
14:42:25 INFO - at null.<anonymous> (/builds/slave/test/gaia/node_modules/mocha/lib/runnable.js:139:19)
14:42:25 INFO - at Timer.listOnTimeout [as ontimeout] (timers.js:110:15)
14:42:25 INFO - TEST-END | build/test/integration/optimized_test.js | GAIA_OPTIMIZE=1 make with GAIA_OPTIMIZE=1 BUILD_DEBUG=1 took 300012 ms
14:42:28 INFO - TEST-START | build/test/integration/production_test.js | PRODUCTION=1 make with PRODUCTION=1
14:47:28 INFO - TEST-UNEXPECTED-FAIL | build/test/integration/production_test.js | PRODUCTION=1 make with PRODUCTION=1
14:47:28 INFO - Error: timeout of 300000ms exceeded
14:47:28 INFO - at null.<anonymous> (/builds/slave/test/gaia/node_modules/mocha/lib/runnable.js:139:19)
14:47:28 INFO - at Timer.listOnTimeout [as ontimeout] (timers.js:110:15)
14:47:28 INFO - TEST-END | build/test/integration/production_test.js | PRODUCTION=1 make with PRODUCTION=1 took 300017 ms
14:47:31 INFO - TEST-START | build/test/integration/shared_css_test.js | shared CSS make APP=test-shared-css, checking shared css are imported
14:47:31 INFO - TEST-UNEXPECTED-FAIL | build/test/integration/shared_css_test.js | shared CSS make APP=test-shared-css, checking shared css are imported
14:47:31 INFO - Error: ENOENT, no such file or directory '/builds/slave/test/gaia/profile/settings.json'
14:47:31 INFO - at Object.fs.openSync (fs.js:427:18)
14:47:31 INFO - at Object.fs.readFileSync (fs.js:284:15)
14:47:31 INFO - at /builds/slave/test/gaia/build/test/integration/production_test.js:21:36
14:47:31 INFO - at ChildProcess.exithandler (child_process.js:635:7)
14:47:31 INFO - at ChildProcess.EventEmitter.emit (events.js:98:17)
14:47:31 INFO - at maybeClose (child_process.js:735:16)
14:47:31 INFO - at Process.ChildProcess._handle.onexit (child_process.js:802:5)
14:47:31 INFO - TEST-END | build/test/integration/shared_css_test.js | shared CSS make APP=test-shared-css, checking shared css are imported took NaN ms
14:47:31 INFO - *~*~* Results *~*~*
14:47:31 INFO - passed: 58
14:47:31 INFO - failed: 3
14:47:31 INFO - todo: 1
14:47:31 INFO - [92m [0m[32m 58 passing[0m[90m (39m)[0m
14:47:31 INFO - [36m [0m[36m 1 pending[0m
14:47:31 INFO - [31m 3 failing[0m
14:47:31 INFO - [0m 1) GAIA_OPTIMIZE=1 make with GAIA_OPTIMIZE=1 BUILD_DEBUG=1:
14:47:31 INFO - [0m[31m Error: timeout of 300000ms exceeded[0m[90m
14:47:31 INFO - at null.<anonymous> (/builds/slave/test/gaia/node_modules/mocha/lib/runnable.js:139:19)
14:47:31 INFO - at Timer.listOnTimeout [as ontimeout] (timers.js:110:15)
14:47:31 INFO - [0m
14:47:31 INFO - [0m 2) PRODUCTION=1 make with PRODUCTION=1:
14:47:31 INFO - [0m[31m Error: timeout of 300000ms exceeded[0m[90m
14:47:31 INFO - at null.<anonymous> (/builds/slave/test/gaia/node_modules/mocha/lib/runnable.js:139:19)
14:47:31 INFO - at Timer.listOnTimeout [as ontimeout] (timers.js:110:15)
14:47:31 INFO - [0m
14:47:31 INFO - [0m 3) shared CSS make APP=test-shared-css, checking shared css are imported:
14:47:31 INFO - [0m[31m Uncaught Error: ENOENT, no such file or directory '/builds/slave/test/gaia/profile/settings.json'[0m[90m
14:47:31 INFO - at Object.fs.openSync (fs.js:427:18)
14:47:31 INFO - at Object.fs.readFileSync (fs.js:284:15)
14:47:31 INFO - at /builds/slave/test/gaia/build/test/integration/production_test.js:21:36
14:47:31 INFO - at ChildProcess.exithandler (child_process.js:635:7)
14:47:31 INFO - at ChildProcess.EventEmitter.emit (events.js:98:17)
14:47:31 INFO - at maybeClose (child_process.js:735:16)
14:47:31 INFO - at Process.ChildProcess._handle.onexit (child_process.js:802:5)
14:47:31 INFO - [0m
14:47:32 INFO - make: *** [build-test-integration] Error 3
14:47:32 ERROR - Return code: 2
14:47:32 INFO - TinderboxPrint: gaia-build-integration-tests: 58/<em class="testfail">3</em>/1
14:47:32 ERROR - Tests exited with return code 2: harness failures
14:47:32 ERROR - # TBPL FAILURE #
14:47:32 INFO - Running post-action listener: _resource_record_post_action
14:47:32 INFO - Running post-run listener: _resource_record_post_run
14:47:33 INFO - Total resource usage - Wall time: 2586s; CPU: 95.0%; Read bytes: 277524480; Write bytes: 4684902400; Read time: 13392; Write time: 8454144
14:47:33 INFO - install - Wall time: 40s; CPU: 100.0%; Read bytes: 0; Write bytes: 83685376; Read time: 0; Write time: 412988
14:47:33 INFO - run-tests - Wall time: 2546s; CPU: 95.0%; Read bytes: 276856832; Write bytes: 4583407616; Read time: 13364; Write time: 7990304
14:47:33 INFO - Running post-run listener: _upload_blobber_files
14:47:33 WARNING - Blob upload gear skipped. Missing cmdline options.
14:47:33 INFO - Copying logs to upload dir...
14:47:33 INFO - mkdir: /builds/slave/test/build/upload/logs
program finished with exit code 2
Flags: needinfo?(ricky060709)
Assignee: nobody → gduan
the problems are all about timeout issue
Attached file PR to master
Hi Ricky,
"GAIA_OPTIMIZE=1 BUILD_DEBUG=1 make" takes too much time as the apps grow. It's time to extend the timeout.
Attachment #8557704 - Flags: review?(ricky060709)
Comment on attachment 8557704 [details] [review]
PR to master

r+
Flags: needinfo?(ricky060709)
Attachment #8557704 - Flags: review?(ricky060709) → review+
Status: NEW → ASSIGNED
land to master: https://github.com/mozilla-b2g/gaia/pull/27838

I'll keep it opened today and see if the problem still exist.
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
This is quite obviously happening again and contributing to a currently unacceptably-high failure rate. We're facing hiding this suite by default if something isn't done to address these issues soon.
Status: RESOLVED → REOPENED
Flags: needinfo?(rchien)
Resolution: FIXED → ---
Would it be possible to have some links to some offenders here? If it's the same issue where it's just that the build is taking longer than it used to, we can easily increase the timeout right now.
See all the Treeherder Robot comments above yours. They're collapsed by default.
You'd think it was my first day using bugzilla. *sigh*. Anyway, it looks like this issue is a dupe of bug bug1188585 which I think I just fixed (I hope). This should show immediate signs of improvement once the bumper bot pushes the new gaia rev.
I didn't see this happen again after bug 1188585 is fixed. According to comment 49, I'm going to mark it as dup of bug 1188585.

Thanks for aus's help.
Status: REOPENED → RESOLVED
Closed: 7 years ago6 years ago
Flags: needinfo?(rchien)
Resolution: --- → DUPLICATE
Duplicate of bug: 1188585
You need to log in before you can comment on or make changes to this bug.