[e10s] Graphic corruption when toggle sidebar after landing bug 1095754

RESOLVED DUPLICATE of bug 1137944

Status

()

Core
Graphics: Layers
RESOLVED DUPLICATE of bug 1137944
3 years ago
3 years ago

People

(Reporter: Alice0775 White, Assigned: jimm)

Tracking

({regression})

38 Branch
x86_64
Windows 7
regression
Points:
---

Firefox Tracking Flags

(e10s+)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8556754 [details]
screenshot

Build Identifier:
https://hg.mozilla.org/integration/mozilla-inbound/rev/5969eb0fe8b5
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:38.0) Gecko/20100101 Firefox/38.0 ID:20150129120229

I notice the problem when I test Bug 1106243.
Graphic corruption when toggle sidebar after landing bug 1095754

Steps To Reproduce:
0. Open e10s window
1. Open http://edition.cnn.com in [Tab 2] and play back any flash video (eg. http://edition.cnn.com/2014/11/23/showbiz/music/katy-perry-super-bowl/index.html?hpt=en_bn1)
2. Toggle Sidebar (Ctrl+B) (several times if need)

Actual Results:
 Graphic corruption

Expected Results:
 No graphic corruption

Regression window
Good:
https://hg.mozilla.org/integration/mozilla-inbound/rev/741a15659b09
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:38.0) Gecko/20100101 Firefox/38.0 ID:20150129102430
Bad
https://hg.mozilla.org/integration/mozilla-inbound/rev/5969eb0fe8b5
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:38.0) Gecko/20100101 Firefox/38.0 ID:20150129120229
Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=741a15659b09&tochange=5969eb0fe8b5

Suspect : Bug 1095754


Graphics
--------

Adapter Description: AMD Radeon HD 6450
Adapter Drivers: aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
Adapter RAM: 1024
ClearType Parameters: Gamma: 2200 Pixel Structure: R ClearType Level: 100 Enhanced Contrast: 200
Device ID: 0x6779
Direct2D Enabled: true
DirectWrite Enabled: true (6.2.9200.16571)
Driver Date: 11-20-2014
Driver Version: 14.501.1003.0
GPU #2 Active: false
GPU Accelerated Windows: 1/1 Direct3D 11 (OMTC)
Subsys ID: 23111787
Vendor ID: 0x1002
WebGL Renderer: Google Inc. -- ANGLE (AMD Radeon HD 6450 Direct3D11 vs_5_0 ps_5_0)
windowLayerManagerRemote: true
AzureCanvasBackend: direct2d 1.1
AzureContentBackend: direct2d 1.1
AzureFallbackCanvasBackend: cairo
AzureSkiaAccelerated: 0
(Reporter)

Comment 1

3 years ago
Err

Steps To Reproduce:
0. Open e10s window
1. Open http://edition.cnn.com and play back any flash video (eg. http://edition.cnn.com/2014/11/23/showbiz/music/katy-perry-super-bowl/index.html?hpt=en_bn1)
2. Toggle Sidebar (Ctrl+B) (several times if need)

Comment 2

3 years ago
I have weird problem as well in e10s mode. When using 9 tiled tabs (zoomed out) images sometimes disappear and reappear (mostly when changing site in any tiled tab). Sometimes trying to drag the image make all images in tiled tabs reappear, but when changing at least one tiled tab URL, some randomly disappear in other tabs. If it's not the same/similar problem, then ignore this comment. :)

Not sure if that's the same issue...
(Reporter)

Comment 3

3 years ago
@Mr_KrzYch00, 
Probably, your problem is different.
Please file a new bug.
Flags: needinfo?(mr.krzych00)
(Assignee)

Comment 4

3 years ago
I've noticed this anomaly as well. The tear is in an area where the plugin child window was located, but has moved away from.
Blocks: 874016
(Assignee)

Updated

3 years ago
Assignee: nobody → jmathies
tracking-e10s: ? → m6+
(Assignee)

Updated

3 years ago
Duplicate of this bug: 1131839
(Assignee)

Updated

3 years ago
Flags: needinfo?(mr.krzych00)
(Assignee)

Updated

3 years ago
No longer blocks: 874016, 1095754
Depends on: 1137944
(Assignee)

Updated

3 years ago
No longer depends on: 1137944
(Assignee)

Updated

3 years ago
Depends on: 1138181
(Assignee)

Updated

3 years ago
Depends on: 1137944
No longer depends on: 1138181
(Assignee)

Comment 6

3 years ago
this is a dupe of the parent, which blocks m6. keeping this around for verification.
tracking-e10s: m6+ → +
(Assignee)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
No longer depends on: 1137944
Resolution: --- → DUPLICATE
Duplicate of bug: 1137944
You need to log in before you can comment on or make changes to this bug.