[Settings] When setting up a passcode, the blank button will behave like the delete key

RESOLVED DUPLICATE of bug 1105041

Status

RESOLVED DUPLICATE of bug 1105041
4 years ago
4 years ago

People

(Reporter: dharris, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v2.0 unaffected, b2g-v2.1 affected, b2g-v2.2 affected, b2g-master affected)

Details

(Whiteboard: [3.0-Daily-Testing], URL)

Attachments

(1 attachment)

Created attachment 8556764 [details]
Screen Lock Logcat

Description:
When the user is setting a passcode from the settings app, in the  bottom left hand corner there is a blank key. If the user taps on that key, it will behave like the delete key.

Prerequisites: Do not have a passcode enabled already

Repro Steps:
1) Update a Flame to 20150129010239
2) Open settings app> Screen Lock
3) Toggle passcode lock on
4) Type at least 1 number
5) Tap on the blank key in the bottom left

Actual:
Characters will be deleted

Expected:
Nothing happens. The key is just a blank space

Environmental Variables:
Device: Flame Master (319mb)(Kitkat)(Full Flash)
Build ID: 20150129010239
Gaia: 9d2378a9ef092ab1fc15c3a9f7fc4171aab59d57
Gecko: 6bfc0e1c4b29
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (Master)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

Repro frequency: 10/10
See attached: Logcat, Video - http://youtu.be/Gz3c-YkKIF0
This bug DOES occur on Flame 2.2, and Flame 2.1

The blank space behaves like the delete key

Environmental Variables:
Device: Flame 2.2 (319mb)(Kitkat)(Full Flash)
Build ID: 20150127002504
Gaia: 80d5b797fd0497a7e3337b7798a21b2e1219681a
Gecko: 01bf1516a65b
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0


Environmental Variables:
Device: Flame 2.1 (319mb)(Kitkat)(Full Flash)
Build ID: 20150129003733
Gaia: 9df43e6e696da43b6a1433283dc5b155987747bc
Gecko: 095a46f32cd4
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 34.0 (2.1)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
_________________________________________________________________________________________

This issue does NOT reproduce on Flame 2.0

When the blank space is tapped, nothing happens.

Environmental Variables:
Device: Flame 2.0 (319mb)(Kitkat)(Full Flash)
Build ID: 20150128000201
Gaia: 2989f2b2bd12fcc0e9c017d2db766e76a55873b8
Gecko: 5bf8087572c3
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 32.0 (2.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Status: NEW → RESOLVED
Last Resolved: 4 years ago
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Resolution: --- → DUPLICATE
Duplicate of bug: 1105041
Flags: needinfo?(pbylenga)
You need to log in before you can comment on or make changes to this bug.