e10s : Pointer Lock / Sensitivity breaks BananaBread

RESOLVED DUPLICATE of bug 1085567

Status

()

defect
RESOLVED DUPLICATE of bug 1085567
4 years ago
2 months ago

People

(Reporter: lukebenes, Unassigned)

Tracking

(Blocks 1 bug)

38 Branch
x86_64
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(e10s?)

Details

Reporter

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:38.0) Gecko/20100101 Firefox/38.0
Build ID: 20150129030202

Steps to reproduce:

1. Go to https://developer.mozilla.org/en-US/demos/detail/bananabread
2. Start any Map




Actual results:

On the nightly builds of Firefox, the pointer lock is broken and the sensitivity is set to godlike levels. Turning system and game sensitivity down, helps, but is still unplayable.


Expected results:

35.0.1 - Good
37.0a2 (2015-01-29) aurora - good 
38.0a1 (2015-01-29) Nightly - BAD

With this I ran a mozregression --good 2014-9-20 --bad 2014-11-20 

MainThread Bisector INFO Got as far as we can go bisecting nightli
es...
MainThread Bisector INFO Last good revision: 2114ef80f6ae
MainThread Bisector INFO First bad revision: b62ccf3228ba
MainThread Bisector INFO Pushlog:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=2114ef80f6ae&tocha
nge=b62ccf3228ba


From this, https://hg.mozilla.org/mozilla-central/rev/b1e482f69d96 looks to be a likely cause of the regression.
Note that if the Jan 29 aurora build is good but Jan 29 nightly is bad then it's quite likely that the regression is recent (after Jan 12th) so the regression range of Nov 7th seems suspect. Also the changeset of mine that you identified should not have caused anything like this; I'm not sure what reasoning you used to pick that one out of the range.
Confirmed in 38.0a1 (2015-02-02) Win 7
Blocks: gecko-games
Status: UNCONFIRMED → NEW
Component: Untriaged → Event Handling
Ever confirmed: true
Product: Firefox → Core
Version: Firefox 38 → 38 Branch
This sounds like bug 1085567 - pointer lock is broken on e10s, which is only on by default on nightly. If that's the case, you should see things working ok when you open a non-e10s window.
Reporter

Comment 4

4 years ago
Good call Alon. Yes, disabling e10s resolves the PointerLock/Sensitivity issue. I've closed this issue.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
tracking-e10s: --- → ?
Resolution: --- → DUPLICATE
Summary: Pointer Lock / Sensitivity Regression breaks BananaBread → e10s : Pointer Lock / Sensitivity breaks BananaBread
Duplicate of bug: 1085567
Component: Event Handling → User events and focus handling
Product: Core → Core
You need to log in before you can comment on or make changes to this bug.