Closed Bug 1127661 Opened 7 years ago Closed 7 years ago

Drag the touch caret is easy to trigger word selection

Categories

(Firefox OS Graveyard :: General, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(firefox36 wontfix, firefox37 wontfix, firefox38 fixed, b2g-v2.2 fixed, b2g-master fixed)

RESOLVED FIXED
2.2 S5 (6feb)
Tracking Status
firefox36 --- wontfix
firefox37 --- wontfix
firefox38 --- fixed
b2g-v2.2 --- fixed
b2g-master --- fixed

People

(Reporter: pchang, Assigned: chenpighead)

References

Details

(Whiteboard: [2.2-CP-bug-bash])

Attachments

(1 file)

Description
Drag the touch caret is easy to trigger word selection


Steps to Reproduce
a. Drag the touch caret
b. move the touch caret

Expected Results
a. Only see touch caret

Actual Results
some words are selected

Other Notes


Reproduction Frequency: high
Assignee: nobody → jeremychen
Consume long tap event which is sent by async-pan-zoom, so that select word will not be triggered anymore while dragging the touch caret.
Attachment #8558444 - Flags: review?(roc)
Comment on attachment 8558444 [details] [diff] [review]
Disable long tap event from APZ while dragging the touch caret v1

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: User would hard to drag touch caret
Testing completed: Try is positive on master try
Risk to taking this patch (and alternatives if risky): low risk
String or UUID changes made by this patch:not available
Attachment #8558444 - Flags: approval-mozilla-b2g37?
https://hg.mozilla.org/mozilla-central/rev/4dec145df0ee
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.2 S5 (6feb)
Attachment #8558444 - Flags: approval-mozilla-b2g37? → approval-mozilla-b2g37+
You need to log in before you can comment on or make changes to this bug.