[FFOS2.0][Woodduck][GCF]Device can not broswer the website in the test server

RESOLVED INVALID

Status

Firefox OS
Gaia::Browser
P1
normal
RESOLVED INVALID
3 years ago
3 years ago

People

(Reporter: pengfei.huang, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

8.60 MB, application/x-rar-compressed
Details
3.25 MB, application/x-rar-compressed
Details
5.78 MB, application/x-rar-compressed
Details
6.95 MB, application/x-rar-compressed
Details
(Reporter)

Description

3 years ago
Created attachment 8556821 [details]
mtklog27.22.7.9.1.1.rar

DEFECT DESCRIPTION:
Device can not broswer the website in the test server

 REPRODUCING PROCEDURES:
When test GCF case 27.22.7.9.1/1, we need broswer the website in the test
server, input website address http://xxx.yyy.zzz, but device can not broswer
this website.

 EXPECTED BEHAVIOUR:
Devide should browser this website successfully to pass this case

 ASSOCIATE SPECIFICATION:

 TEST PLAN REFERENCE:

 TOOLS AND PLATFORMS USED:

 USER IMPACT:

 REPRODUCING RATE:

 For FT PR, Please list reference mobile's behavior:

 Reporter phone number:0752-2639862(61862)

Comment 1

3 years ago
Hi PengFei,
Are you sure http://xxx.yyy.zzz is a correct server address?
Can you open this webpage with other device or desktop?
Flags: needinfo?(pengfei.huang.hz)

Comment 2

3 years ago
Please TCL network team to check this issue first.

All we can see is data get connected, interface/ip are ready too.

01-23 03:47:35.355   165   417 I Gonk    : Connected to netd
01-23 03:47:35.363   165   896 D DHCP    : ifc_add_route(ccmni0, 192.168.1.1, 32, 200.1.1.80) = 0
01-23 03:47:35.364   165   896 D DHCP    : ifc_create_default_route(ccmni0, 1342243272) = 0
01-23 03:47:35.417   165   165 I Gecko   : -*- RILContentHelper: Received message 'RIL:DataInfoChanged': {"clientId":0,"data":{"connected":true,"emergencyCallsOnly":false,"roaming":false,"network":{"longName":"00101","shortName":"00101","mcc":"001","mnc":"01"},"cell":{"gsmLocationAreaCode":1,"gsmCellId":0},"type":"umts","signalStrength":-51,"relSignalStrength":100,"state":"registered"}}
Flags: needinfo?(sync-1)

Comment 3

3 years ago
"dnses":[] <- check this part first please.


01-23 03:47:35.247   165   581 I Gecko   : RIL Worker: [0] Handling parcel as REQUEST_SETUP_DATA_CALL
01-23 03:47:35.248   165   581 I Gecko   : RIL Worker: Next parcel size unknown, going to sleep.
01-23 03:47:35.254   165   165 I Gecko   : -*- RadioInterface[0]: Received message from worker: {"status":0,"suggestedRetryTime":0,"cid":"0","active":2,"type":"IP","ifname":"ccmni0","addresses":["200.1.1.80"],"dnses":[],"gateways":["200.1.1.80"],"state":1,"radioTech":3,"apn":"TestGp.rs","user":"","passwd":"","chappap":3,"pdptype":"IP","rilMessageType":"datacallstatechange","rilMessageClientId":0}
(Reporter)

Comment 4

3 years ago
(In reply to Josh Cheng [:josh] from comment #1)
> Hi PengFei,
> Are you sure http://xxx.yyy.zzz is a correct server address?
> Can you open this webpage with other device or desktop?
Dear Josh & Shawn,
  At the lab test, the website is prepared for testing. The URL can visited on lab environment.
  VAL analysis this bug is due to APN. And more analysis I am asking for right guy.
  
  Latest news, Dengwei reminds me the lab will change APN for testing again. It's can be operation mistaken. Please know it.
  Thanks.
Flags: needinfo?(pengfei.huang.hz)

Comment 5

3 years ago
Hi PengFei,
DO you have any update for the root cause? Thanks!
Blocks: 1054172
Flags: needinfo?(pengfei.huang.hz)
OS: Linux → Gonk (Firefox OS)
Hardware: x86_64 → ARM
(Reporter)

Comment 6

3 years ago
(In reply to Josh Cheng [:josh] from comment #5)
> Hi PengFei,
> DO you have any update for the root cause? Thanks!
Hi Josh,
  TMC is retesting. I will update ASAP when receive feedback.
  Thank you.
Flags: needinfo?(pengfei.huang.hz)
(Reporter)

Comment 7

3 years ago
Created attachment 8558234 [details]
mtklog_fail_log.rar

Dear Josh & Shawn,
  TMC test result:failed in lab. can't visit the website.
  VAL test successfully at home. And provide the information as follow,

1. lab fail log:
01-31 10:12:58.036   932   932 I Gecko   : ############################### browserElementPanning.js loaded
01-31 10:12:58.268   932   932 I Gecko   : ######################## BrowserElementChildPreload.js loaded
01-31 10:12:58.688   168   168 E GeckoConsole: [JavaScript Error: "ReferenceError: Awesomescreen is not defined" {file: "app://browser.gaiamobile.org/js/browser.js" line: 1065}]
01-31 10:13:04.220   975   975 I Gecko   : ############################### browserElementPanning.js loaded
01-31 10:13:04.239   975   975 I Gecko   : ######################## BrowserElementChildPreload.js loaded
2. success log:
02-02 09:55:36.664  1128  1128 I Gecko   : ############################### browserElementPanning.js loaded
02-02 09:55:36.681  1128  1128 I Gecko   : ######################## BrowserElementChildPreload.js loaded
02-02 09:56:22.643   162   162 E GeckoConsole: Content JS LOG at app://browser.gaiamobile.org/js/browser_db.js:321 in getIconError: Error fetching icon
02-02 09:56:22.936   919   919 E GeckoConsole: Content JS ERROR at about:neterror?e=proxyResolveFailure&u=http%3A//xxx.yyy.zzz/&c=UTF-8&f=browser&m=app%3A//browser.gaiamobile.org/manifest.webapp&d=Firefox%20is%20configured%20to%20use%20a%20proxy%20server%20that%20can%27t%20be%20found.:1217 in initPage: net-error
02-02 09:56:54.568   162   162 E GeckoConsole: Content JS LOG at app://browser.gaiamobile.org/js/browser_db.js:321 in getIconError: Error fetching icon
02-02 09:56:54.867   919   919 E GeckoConsole: Content JS ERROR at about:neterror?e=proxyResolveFailure&u=http%3A//xxx.yyy.zzz/&c=UTF-8&f=browser&m=app%3A//browser.gaiamobile.org/manifest.webapp&d=Firefox%20is%20configured%20to%20use%20a%20proxy%20server%20that%20can%27t%20be%20found.:1217 in initPage: net-error

  Please help us analysis.Thanks.

Updated

3 years ago
Assignee: nobody → yliao
(Reporter)

Comment 8

3 years ago
Dear Mozilla,
  In the TMC lab environment, VAL confirm the first step(http get) of visiting website not be executed successfully. 
  Does the log key word "dnses" mean DNS?
  Thank you.
01-31 10:12:58.688   168   168 E GeckoConsole: [JavaScript Error: "ReferenceError: Awesomescreen is not defined" {file: "app://browser.gaiamobile.org/js/browser.js" line: 1065}]

I assume this line should have nothing to do with the error. It's because the Awesomescreen javascript file can't be loaded.

02-02 09:56:22.936   919   919 E GeckoConsole: Content JS ERROR at about:neterror?e=proxyResolveFailure&u=http%3A//xxx.yyy.zzz/&c=UTF-8&f=browser&m=app%3A//browser.gaiamobile.org/manifest.webapp&d=Firefox%20is%20configured%20to%20use%20a%20proxy%20server%20that%20can%27t%20be%20found.:1217 in initPage: net-error

The error here specified that 'Firefox is configured to use a proxy server that can't be found.'. It's probably due to your local test network settings.
Assignee: yliao → nobody
(Reporter)

Comment 10

3 years ago
Hi yifan,
  Your analysis is right.
  The success log tested by VAL execute the whole http request and response steps correctly. But the TMC test is fail at http get request even there is no network.

Comment 11

3 years ago
Hi PengFei,
Have your VAL pass the test? Do you still need help?
Flags: needinfo?(pengfei.huang.hz)
Hi josh,

(In reply to Josh Cheng [:josh] from comment #11)
> Hi PengFei,
> Have your VAL pass the test? Do you still need help?

in the lab is still not ok yet.
we don't know why we can't access in the simulation environment.
we still need help.
(Reporter)

Comment 13

3 years ago
Dear Josh,
  The situation now as follow:
  VAL simulate the test at real network and can test pass.
  TMC test is at virtual network with lab device but test fail.
  But we have to figure out why TMC test failed. And VAL engineer confirm TMC fail at http get request even there is no network. So, could help us try more analysis.
Flags: needinfo?(pengfei.huang.hz)

Updated

3 years ago
Flags: needinfo?(yliao)
Sorry that I'm not an expert in the network handling and have no idea what's going on behind the log. We need someone who's specialized in this field. Just in case can other firefox os or android phone pass the test?
Flags: needinfo?(yliao)

Comment 15

3 years ago
Hi PengFei,
Can you provide new log from TMC? 
Thanks!
Flags: needinfo?(pengfei.huang.hz)
(Reporter)

Comment 16

3 years ago
Hi Josh & yifan,
   The attachment mtklog_fail_log.rar on comment7 is the log TMC provided. I and Jiabin will ask VAL provide the Android log for you. we don't know other firefox os whether has the same problem. Woodduck is base on 2.0m.
Flags: needinfo?(pengfei.huang.hz)

Comment 17

3 years ago
Paste mail from PengFei:

VAL的分析和疑问,还请Mozilla帮忙提供答疑,感谢.
    VAL的分析:
     通过log可以看测试使用的APN
     "apn":"TestGp.rs","user":"","password":"","proxy":"192.168.1.1","port":"8080","authtype":"notDefined","protocol":"IP","roaming_protocol":"IP","types"
     Radio log中建立数据链接的时候  requestSetupData profile=0, apn=TestGp.rs, username=, password=xxxx, authType=1, protocol=0, interfaceId=0
   VAL疑问:
     User name为空,password是xxxx,这里也是代表空的意思吗?还有authtype-1代表的又是什么?这里是否有错误,看下面AT有error返回 
     queryMatchedPdnWithSameApn AT+CGCONTRDP response error

Updated

3 years ago
Blocks: 1080337
My colleague analyzed that from the radio log, it seems that the modem didn't respond correct informations. In the radio log ln.5857 the AT+CGCONTRDP didn't provide necessary network parameters so the device couldn't establish a successful connection.

Updated

3 years ago
Flags: needinfo?(pengfei.huang.hz)
(Reporter)

Comment 19

3 years ago
Created attachment 8558952 [details]
Fire2-3.5-web-log.rar

Hi Josh,
  The all log is here.
  per TMC reply mail:
  log anite-network/20150123: can visit website but fail at close browser.
  log anite-network/20150201: can't visit website.
  new log anite-network/20150201-newlog2-: can't visit website.
  log mtklog-2.1-normal network: test on real network and pass.
  Could you please help us do more detail analysis? Many thanks.
Flags: needinfo?(pengfei.huang.hz)
(Reporter)

Comment 20

3 years ago
Dear Mozilla,
  Sync TMC test steps information. TMC test step as follow.
   1.Select STK menu,run "27.22.7.9.1/1" case;
   2.Register a BROWSER_TERMINATION event;
   3.STK menu display a dialog with a URL and user click the URL;
   4.Launch a browser and loading the page;             -----> can't visit page.
   if above steps success,
   5.Close Browser app.
   6.Gaia will send an envelope(Event Download) to sim.

Comment 21

3 years ago
Hi Woodduck,
I need your help to check the radio log from comment 19 per feedback of comment 18. Thanks!

Updated

3 years ago
Flags: needinfo?(wudduc)

Updated

3 years ago
Flags: needinfo?(chien-hao.li)

Comment 22

3 years ago
Hi Wenquan, Please check it. Thanks.
Flags: needinfo?(wudduc)
Flags: needinfo?(wenquan.zhong)
Flags: needinfo?(chien-hao.li)
Hi Pengfei,

In your comment 20, how did SIM card request ME to open URL? '0x15': function STK_CMD_LAUNCH_BROWSER ?
Flags: needinfo?(pengfei.huang.hz)
(Reporter)

Comment 24

3 years ago
(In reply to Sean Lee [:seanlee] from comment #23)
> Hi Pengfei,
> 
> In your comment 20, how did SIM card request ME to open URL? '0x15':
> function STK_CMD_LAUNCH_BROWSER ?
  It's the TMC case implementation. Like executing another case.
Flags: needinfo?(pengfei.huang.hz)
(Reporter)

Comment 25

3 years ago
Created attachment 8561149 [details]
android_mtklog27.22.7.9.1.rar

Dear All,
  Android pass log.

Comment 26

3 years ago
Jibin and Haifang are checking!
Flags: needinfo?(wenquan.zhong)

Updated

3 years ago
Priority: -- → P1

Comment 27

3 years ago
Update: Partner has defer the case as this is Their access point related issue.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(sync-1)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.