[Bluetooth][Text Selection] PIN code on Bluetooth pair request page can be selected

VERIFIED FIXED in 2.2 S5 (6feb)

Status

defect
VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: ashiue, Assigned: iliu)

Tracking

unspecified
2.2 S5 (6feb)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [2.2-CP-bug-bash])

Attachments

(2 attachments)

Reporter

Description

5 years ago
Build ID               20150129003432
Gaia Revision          6e494f1d2676d231abba7dcc2e2822d1170d2d02
Gaia Date              2015-01-29 06:34:56
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/5e6fac01a72f
Gecko Version          37.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150129.042943
Firmware Date          Thu Jan 29 04:29:53 EST 2015
Bootloader             L1TC000118D0


STR:
1. Enable BT on device
2. Try to pair an available device (Tap the device)
3. When the BT request page shows, long press the PIN code

Expected result:
PIN code cannot be selected

Actual result:
PIN code can be selected
Reporter

Updated

5 years ago
Whiteboard: [2.2-CP-bug-bash]
Reporter

Updated

5 years ago
ni? gaia dev Ian.

Ian, the PIN code for pairing should NOT be able to select. Can you disable it on UI?
Flags: needinfo?(iliu)
Set component to Gaia::System since this bug relates to toast for pairing.
Component: Bluetooth → Gaia::System
Posted file pull request 27806
Since test selected feature is landed, we should manually set property '-moz-user-select' for each view/dialog. In this dialog, we should set the property to be none.

George, could you please help to review the patch? I think you are familiar with the feature in Gaia::System. Thanks.
Flags: needinfo?(iliu)
Attachment #8556966 - Flags: review?(gduan)
Comment on attachment 8556966 [details] [review]
pull request 27806

LGTM, r=gduan
Attachment #8556966 - Flags: review?(gduan) → review+
Assignee: nobody → iliu
Comment on attachment 8556966 [details] [review]
pull request 27806

George, I have revised the pull request. Because there are input field when the pairing method is type of pin code. I would like your review again here. Thanks.
Attachment #8556966 - Flags: review+ → review?(gduan)
Comment on attachment 8556966 [details] [review]
pull request 27806

thanks, r=gduan
Attachment #8556966 - Flags: review?(gduan) → review+
Status: NEW → ASSIGNED
Gaia/master:  01158b8e9c0e7c75379b8a1c21e44d868efa2f60
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Will need triage for v2.2.
blocking-b2g: --- → 2.2?
Component: Gaia::System → Gaia::Settings

Comment 9

4 years ago
Triage: blocking as broken new feature. Hi Ian, please request approval for 2.2, thanks.
blocking-b2g: 2.2? → 2.2+
Flags: needinfo?(iliu)
Comment on attachment 8556966 [details] [review]
pull request 27806

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Uncompleted feature from text selected. Follow up text selected pattern.
[User impact] if declined: A user would be able to select text in page of pairing dialog while he/she is confirming the pairing request.
[Testing completed]: Manual test.
[Risk to taking this patch] (and alternatives if risky): Low.
[String changes made]: None.
Flags: needinfo?(iliu)
Attachment #8556966 - Flags: approval-gaia-v2.2?
Reporter

Updated

4 years ago
QA Whiteboard: [COM=Text Selection]
Attachment #8556966 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
Reporter

Comment 12

4 years ago
Verified on
[2.2]
Gaia-Rev        a52999ce7f783177deb17e267bf003a53e6fde06
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/01446d5231ef
Build-ID        20150205162501
Version         37.0a2
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150205.194212
FW-Date         Thu Feb  5 19:42:24 EST 2015
Bootloader      L1TC000118D0

[3.0]
Gaia-Rev        2b83a6d5d1185a438b5bbd287497ac2743b501db
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/34a66aaaca81
Build-ID        20150205010209
Version         38.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150205.044014
FW-Date         Thu Feb  5 04:40:24 EST 2015
Bootloader      L1TC000118D0
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.