[Bluetooth][Text Selection] Try to transfer file via bluetooth, the bluetooth selected page still can use copy-pasty function

VERIFIED FIXED in 2.2 S5 (6feb)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: ashiue, Assigned: iliu)

Tracking

unspecified
2.2 S5 (6feb)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [2.2-CP-bug-bash])

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

4 years ago
Posted image select_bt_list.png
Build ID               20150129003432
Gaia Revision          6e494f1d2676d231abba7dcc2e2822d1170d2d02
Gaia Date              2015-01-29 06:34:56
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/5e6fac01a72f
Gecko Version          37.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150129.042943
Firmware Date          Thu Jan 29 04:29:53 EST 2015
Bootloader             L1TC000118D0

STR:
1. Enable BT on device
2. Go to Music -> select a song -> try to share via bluetooth
3. When in BT lists, long press any listed device

Expected result:
Word should not be selected

Actual result:
Word can be selected
(Reporter)

Updated

4 years ago
Whiteboard: [2.2-CP-bug-bash]
ni? gaia dev Ian.

Ian, the text in pairing screen should NOT be able to select. Can you disable it on UI?
Flags: needinfo?(iliu)
Assignee: nobody → iliu
Flags: needinfo?(iliu)
(In reply to Ben Tian [:btian] from comment #1)
> ni? gaia dev Ian.
> 
> Ian, the text in pairing screen should NOT be able to select. Can you
> disable it on UI?
Sure, we have to disable it to follow text selection pattern.
Posted file pull request 27807 (obsolete) —
George, the other page for fixing text selected in Bluetooth app. It will need your review. Thanks.
Attachment #8556997 - Flags: review?(gduan)
Attachment #8556997 - Flags: review?(gduan) → review+
Since the pull request is landed, we can close the issue now.

Gaia/master: a36f69d395a855b5d6b95a3ac23c2d33760971e2
Comment on attachment 8556997 [details] [review]
pull request 27807

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Follow text selection pattern, bug 1127715.
[User impact] if declined: A user is able to select text while sharing file(s) via Bluetooth.
[Testing completed]: Manual test.
[Risk to taking this patch] (and alternatives if risky): None.
[String changes made]: None.
Attachment #8556997 - Flags: approval-gaia-v2.2?
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
I revert the patch since comment log is not clear enough.

Gaia/master:  6aae88ab205e61f81b6687e2c3fa4fc2f66f7ad9
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Comment on attachment 8556997 [details] [review]
pull request 27807

Will request approval again while the patch is landed.
Attachment #8556997 - Flags: approval-gaia-v2.2?
Status: REOPENED → ASSIGNED
Comment on attachment 8556997 [details] [review]
pull request 27807

Obsolete the pr, since I created a new one.
Attachment #8556997 - Attachment is obsolete: true
Posted file pull request 27845
George, I create a new patch for re-landing. Please help to review it again. Thanks.
Attachment #8557804 - Flags: review?(gduan)
Attachment #8557804 - Flags: review?(gduan) → review+
Gaia/master:  8942bd3df6b830b24ffe4da224c49f1c07015866
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → FIXED
Note: Triage for v2.2
blocking-b2g: --- → 2.2?

Comment 12

4 years ago
Triage: blocking, broken new feature. Hi Ian, please request 2.2 approval, thanks.
blocking-b2g: 2.2? → 2.2+
Flags: needinfo?(iliu)
Comment on attachment 8557804 [details] [review]
pull request 27845

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Uncompleted feature from text selected.
[User impact] if declined: A user would be able to select text in page of turning Bluetooth on, pick remote device while he/she is sending a file via Bluetooth.
[Testing completed]: Manual test.
[Risk to taking this patch] (and alternatives if risky): Low.
[String changes made]: None.
Flags: needinfo?(iliu)
Attachment #8557804 - Flags: approval-gaia-v2.2?
(Reporter)

Updated

4 years ago
QA Whiteboard: [COM=Text Selection]
Attachment #8557804 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
v2.2: https://github.com/mozilla-b2g/gaia/commit/7cf2c18326bc16ddb9d9945084b677914a87160c

FWIW, you don't need to set checkin-needed on these. They show up in the uplift queries just fine without :)
Keywords: checkin-needed
Target Milestone: --- → 2.2 S5 (6feb)
(Reporter)

Comment 15

4 years ago
Verified on
[2.2]
Gaia-Rev        a52999ce7f783177deb17e267bf003a53e6fde06
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/01446d5231ef
Build-ID        20150205162501
Version         37.0a2
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150205.194212
FW-Date         Thu Feb  5 19:42:24 EST 2015
Bootloader      L1TC000118D0

[3.0]
Gaia-Rev        2b83a6d5d1185a438b5bbd287497ac2743b501db
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/34a66aaaca81
Build-ID        20150205010209
Version         38.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150205.044014
FW-Date         Thu Feb  5 04:40:24 EST 2015
Bootloader      L1TC000118D0
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.