[Messages] "Message" in sms options can be selected

VERIFIED FIXED in Firefox OS v2.2

Status

Firefox OS
Gaia::SMS
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: ericcc, Assigned: steveck)

Tracking

unspecified
2.2 S7 (6mar)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [2.2-CP-bug-bash])

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8556974 [details]
2015-01-30-10-47-58.png

*** Steps to Reproduce
1. Create a new message
2. Tap 3 dots to options
3. Long tap on "Message"
 
*** Expected Results
"Message" not selected.

*** Actual Results
"Message" selected.

*** Reproduction Frequency: 100%

*** Version
Serial: e47cd843 (State: device)
Build ID               20150129003432
Gaia Revision          6e494f1d2676d231abba7dcc2e2822d1170d2d02
Gaia Date              2015-01-29 06:34:56
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/5e6fac01a72f
Gecko Version          37.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150129.042943
Firmware Date          Thu Jan 29 04:29:53 EST 2015
Bootloader             L1TC000118D0
(Reporter)

Updated

3 years ago
QA Whiteboard: [COM=Gaia::Messages]
Triage: New functionality which might appear as broken for an end user.
blocking-b2g: 2.2? → 2.2+
(Assignee)

Comment 2

3 years ago
I think some widgets are missing the user-select: none, will provide some general solution for all widgets.
Also occurring in master so marking "status-b2g-v3.0" as affected.

Environmental variables:
Flame 3.0 device
Build Id: 20150130082956
Gecko: 8e96000
Gaia: 21829dd
Platform version: 38.0a1
status-b2g-master: --- → affected

Updated

3 years ago
QA Whiteboard: [COM=Gaia::Messages] → [COM=Gaia::SMS]
(Assignee)

Updated

3 years ago
Assignee: nobody → schung
Depends on: 1129356
This issue should be fixed once Bug 1127658 landed. (Steve, please correct if I'm wrong :) )
(Assignee)

Comment 5

3 years ago
(In reply to Julien Wajsberg [:julienw] from comment #4)
> This issue should be fixed once Bug 1127658 landed. (Steve, please correct
> if I'm wrong :) )

Ya right, I was thinking that we could fix these selection issues all at once in bug 1127587, but it's not blocker right now and need more details right now. Maybe we should land a simpler patch for Bug 1127658 and this bug first.
(Assignee)

Comment 6

3 years ago
Mark fixed since patch for bug 1127658 already landed and the it also fixed this issue as well.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
status-b2g-v2.2: affected → fixed
status-b2g-master: affected → fixed
Target Milestone: --- → 2.2 S7 (6mar)
This issue is verified fixed on the latest Nightly Flame 3.0 and 2.2 builds.

Actual Results: The Message text cannot be selected with the text selection.

Environmental Variables:
Device: Flame 3.0 KK (Full Flash) (319 MB)
BuildID: 20150312010235
Gaia: 0c4e8b0b330757e261b031b7e7f326ef419c9808
Gecko: 5334d2bead3e
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 39.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Environmental Variables:
Device: Flame 2.2 KK (Full Flash) (319 MB)
BuildID: 20150312002501
Gaia: 572d60e0a440ee4af50bc6b6adad8876eadbdb4d
Gecko: 244e6ba3c20e
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [COM=Gaia::SMS] → [COM=Gaia::SMS][QAnalyst-Triage?]
status-b2g-v2.2: fixed → verified
status-b2g-master: fixed → verified
Flags: needinfo?(ktucker)
QA Whiteboard: [COM=Gaia::SMS][QAnalyst-Triage?] → [COM=Gaia::SMS][QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.