Closed Bug 11279 Opened 21 years ago Closed 21 years ago

[BLOCKER][CRASHER]Posting a form several times causes the browser to crash

Categories

(Core :: DOM: Core & HTML, defect, P1, blocker)

defect

Tracking

()

VERIFIED FIXED

People

(Reporter: gerardok, Assigned: gagan)

References

()

Details

Overview Description:

When a form is submitted 3-6 times, using the POST method, the browser crashes
at on all platforms.

Steps to Reproduce:

1) Load the following URL in the browser:

bubblegum/test1/form.html

where the HTML file content is:

<HTML>
<HEAD>
<TITLE>Form Submission Test</TITLE>
</HEAD>
<BODY>

<FORM ACTION="/gerardok/cgi/cgitest.cgi" METHOD="post">
<INPUT TYPE="text" NAME="name">
<INPUT TYPE="submit">
</FORM>

</BODY>
</HTML>

2) Fill in the text input field and click on the submit button. It would submit
the data to rhe following cgi:

#!/usr/local/bin/perl
require "cgi-lib.pl";

&ReadParse(*input);

print "Content-type: text/html", "\n\n";

print "<HTML>\n";
print "<HEAD>\n";
print "<TITLE>CGI Test</TITLE>\n";
print "</HEAD>\n";
print "<BODY>\n";
print "<H1>Welcome to Bubblegum Server!</H1>\n";
print "Parameter: $input{'name'}\n";
print "</BODY>\n";
print "</HTML>\n";

exit(0);

3) You should get a cgi reponse as:

Welcome to Bubblegum Server!
Parameter: <your input>

4) Try repeating steps 1-3 around six times.

Actual Results: Browser crashes

Expected Results: The cgi response displayed as above

Build ID & Platform Bug Found: 1999-08-04-09-M9 on Win NT

Additional Builds and Platforms Tested On: 1999-08-04-09 on Mac OS

Additional Information: n/a
Priority: P3 → P1
QA Contact: cpratt → gerardok
Target Milestone: M9
Talkback Incident ID: 12027082

 Call Stack:    (Signature = nsHTTPChannel::~nsHTTPChannel 3e69356b)

   nsHTTPChannel::~nsHTTPChannel
[d:\builds\seamonkey\mozilla\netwerk\protocol\http\src\nsHTTPChannel.cpp, line
81]

   nsHTTPChannel::`scalar deleting
   destructor'


   nsHTTPChannel::Release
[d:\builds\seamonkey\mozilla\netwerk\protocol\http\src\nsHTTPChannel.cpp, line
111]

   nsDocLoaderImpl::SetDocumentChannel
[d:\builds\seamonkey\mozilla\webshell\src\nsDocLoader.cpp, line 1401]

   nsDocumentBindInfo::Bind
[d:\builds\seamonkey\mozilla\webshell\src\nsDocLoader.cpp, line 1623]

   nsDocumentBindInfo::Bind
[d:\builds\seamonkey\mozilla\webshell\src\nsDocLoader.cpp, line 1623]

   nsDocLoaderImpl::LoadDocument
[d:\builds\seamonkey\mozilla\webshell\src\nsDocLoader.cpp, line 678]

   nsWebShell::DoLoadURL
[d:\builds\seamonkey\mozilla\webshell\src\nsWebShell.cpp, line 1978]

   nsWebShell::LoadURL
[d:\builds\seamonkey\mozilla\webshell\src\nsWebShell.cpp, line 2148]

   nsWebShell::LoadURL
[d:\builds\seamonkey\mozilla\webshell\src\nsWebShell.cpp, line 1815]

   nsBrowserAppCore::LoadUrl
[d:\builds\seamonkey\mozilla\xpfe\AppCores\src\nsBrowserAppCore.cpp, line 824]

   BrowserAppCoreLoadUrl
[d:\builds\seamonkey\mozilla\xpfe\AppCores\src\nsJSBrowserAppCore.cpp, line 390]

   js_Invoke
[d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 655]

   js_Interpret
[d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 2229]

   js_Invoke
[d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 675]

   js_Interpret
[d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 2229]

   js_Invoke
[d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 675]

   js_InternalCall
[d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 748]

   JS_CallFunctionValue
[d:\builds\seamonkey\mozilla\js\src\jsapi.c, line 2645]

   nsJSEventListener::HandleEvent
[d:\builds\seamonkey\mozilla\dom\src\events\nsJSEventListener.cpp, line 98]

   nsEventListenerManager::HandleEvent
[d:\builds\seamonkey\mozilla\layout\events\src\nsEventListenerManager.cpp, line
796]

   nsGenericElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\layout\base\src\nsGenericElement.cpp, line 784]

   nsHTMLInputElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\layout\html\content\src\nsHTMLInputElement.cpp,
line 511]

   PresShell::HandleEvent
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 2036]

   nsView::HandleEvent
[d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 834]

   nsView::HandleEvent
[d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 819]

   nsViewManager::DispatchEvent
[d:\builds\seamonkey\mozilla\view\src\nsViewManager.cpp, line 1611]

   HandleEvent
[d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 67]

   nsWindow::DispatchEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 494]

   nsWindow::DispatchWindowEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 515]

   nsWindow::DispatchKeyEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 1960]

   nsWindow::OnKeyUp
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 2221]

   nsWindow::ProcessMessage
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 2468]

   nsWindow::WindowProc
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 564]

   nsTextWidget::TextWindowProc
[d:\builds\seamonkey\mozilla\widget\src\windows\nsTextWidget.cpp, line 120]

   USER32.dll + 0x1250 (0x77e71250)

   0xc01c0001
Assignee: karnaze → gagan
gagan, reassigning to you as you fixed POSTing lately.
Summary: Posting a form several times causes the browser to crash → [CRASHER]Posting a form several times causes the browser to crash
Severity: critical → blocker
Summary: [CRASHER]Posting a form several times causes the browser to crash → [BLOCKER][CRASHER]Posting a form several times causes the browser to crash
This bug is blocking QA Browser automation, can this be fixed ASAP please?
Blocks: 11349
I thought mcafee fixed posting. Cc'ing him.
This bug looks like it's been fixed on 1999-08-11-09 build.
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
Excellent!! Marking Verified...whooo-hooo!
Component: HTML: Form Submission → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.