Closed Bug 1127950 Opened 5 years ago Closed 5 years ago

OS X 10.10 modal dialog's default button is blank if open when Firefox doesn't have focus

Categories

(Core :: Widget: Cocoa, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1100401
Tracking Status
firefox35 --- affected
firefox36 --- affected
firefox37 --- affected
firefox38 --- affected

People

(Reporter: cpeterson, Unassigned)

References

Details

(Keywords: reproducible)

This bug is basically the same as bug 1106906 except the modal dialog must open when when the Firefox window does NOT have input focus.

This does not seem to be a regression because I can reproduce on Nightly 38, Aurora 37, Beta 36, and Firefox 35. I am running OS X 10.10. I can reproduce this bug with or without e10s.

STR:
1. Open https://phonebook.mozilla.org
2. Cancel the "Authentication Required" dialog
3. Ensure you have the "Show my windows and tabs from last time" preference.
4. Quit Firefox
5. Reopen Firefox
6. QUICKLY switch focus to a different application!
7. Firefox's application icon will bounce on the dock because it is blocked on the Phonebook's "Authentication Required" dialog
8. Switch focus back to Firefox

RESULT:
The "Authentication Required" dialog's default button ("OK") will be blank.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1100401
You need to log in before you can comment on or make changes to this bug.