[Calendar] month view: "other month" label should be set as aria-label instead of hidden text

RESOLVED FIXED in Firefox OS v2.2

Status

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: mmedeiros, Assigned: obara.justin)

Tracking

({late-l10n})

unspecified
2.2 S5 (6feb)
x86
Mac OS X
late-l10n

Firefox Tracking Flags

(b2g-v2.2 fixed, b2g-master fixed)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

4 years ago
Created attachment 8557236 [details]
other-month-label.png

right now the string "other month" is set on the markup:

<li class="past other-month" data-date="d-2014-11-28" aria-describedby="month-view-day-d-2014-11-28-busy-indicator month-view-day-d-2014-11-28-description" id="month-view-day-d-2014-11-28" role="gridcell">
  <span class="day" role="button">28</span>
  <div id="month-view-day-d-2014-11-28-busy-indicator" class="busy-indicator" aria-hidden="true"></div>
  <span id="month-view-day-d-2014-11-28-description" aria-hidden="true" data-l10n-id="past-other-month">Other month</span>
</li>

`past-other-month` and `future-other-month` should probably use the ariaLabel instead of setting the textContent.

in some languages that doesn't use the latin alphabet you can actually see some artifacts caused by the hidden text (they overflow a little bit) - see attached screenshot
(Reporter)

Updated

4 years ago
Blocks: 893789
See Also: → bug 1102506
(Assignee)

Updated

4 years ago
Assignee: nobody → obara.justin
Created attachment 8558238 [details] [review]
[PullReq] jobara:1127955 to mozilla-b2g:master
(Assignee)

Comment 2

4 years ago
Created attachment 8558239 [details] [review]
Converted the past-other-month and future-other-month to be aria-labels instead of text nodes.
Attachment #8558239 - Flags: a11y-review?(yzenevich)
Autolander will automatically attach patches for you from now, so please use the attachment next time that it generates if possible. For more info see the announcement here: https://groups.google.com/forum/#!topic/mozilla.dev.gaia/cTevbcnUr38 Let me know if you have any problems or suggestions about how to improve the process. Thanks!
(Assignee)

Updated

4 years ago
Attachment #8558238 - Flags: a11y-review?(yzenevich)

Updated

4 years ago
Attachment #8558239 - Attachment is obsolete: true
Attachment #8558239 - Flags: a11y-review?(yzenevich)
Comment on attachment 8558238 [details] [review]
[PullReq] jobara:1127955 to mozilla-b2g:master

Looks good from a11y standpoint. Please rename the keys though to something new (see github comment). Mark miller for review once the comment is addressed. Thanks a lot, Justin!
Attachment #8558238 - Flags: a11y-review?(yzenevich) → a11y-review+
(Assignee)

Updated

4 years ago
Attachment #8558238 - Flags: review?(mmedeiros)
(Reporter)

Updated

4 years ago
Attachment #8558238 - Flags: review?(mmedeiros) → review+
(Assignee)

Updated

4 years ago
Keywords: checkin-needed

Updated

4 years ago
Keywords: checkin-needed

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Reporter)

Updated

4 years ago
Duplicate of this bug: 1096547
Comment on attachment 8558238 [details] [review]
[PullReq] jobara:1127955 to mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): improvement, not a bug
[User impact] if declined: screen reader actually reads off transparent text rather than a proper label.
[Testing completed]: unit and on device
[Risk to taking this patch] (and alternatives if risky): low
[String changes made]: https://github.com/mozilla-b2g/gaia/pull/27866/files#diff-97b7fed57927556b91fb72d4d1b8c8b5
Attachment #8558238 - Flags: approval-gaia-v2.2?

Updated

4 years ago
Keywords: late-l10n

Updated

4 years ago
Attachment #8558238 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
v2.2: https://github.com/mozilla-b2g/gaia/commit/565ab0585e7db2da83659457e21422c2ecb1f085
status-b2g-v2.2: --- → fixed
status-b2g-master: --- → fixed
Target Milestone: --- → 2.2 S5 (6feb)
You need to log in before you can comment on or make changes to this bug.