On Twitter's flash fallback for h.264 video, the video doesn't zoom until you refresh page

RESOLVED WORKSFORME

Status

()

Core
Layout
RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: dholbert, Unassigned)

Tracking

Trunk
x86_64
Linux
Points:
---

Firefox Tracking Flags

(platform-rel -)

Details

(Whiteboard: [platform-rel-Twitter], URL)

(Reporter)

Description

3 years ago
STR:
 0. Verify that https://www.youtube.com/html5 says your browser does *not* support "H.264"
 1. Visit https://twitter.com/paperbeatstweet/status/561209975146835968
 2. Try to zoom in with Ctrl +, or Ctrl Mousewheel.

 (optional): Reload the page.

ACTUAL RESULTS: When you zoom in, the video stays the same size. (Its content-box grows larger, but it only occupies a portion of its content-box.)  If you reload after zooming, *then* it renders at the right (large) size.
(Reporter)

Comment 1

3 years ago
Should have added to step 1: "Visit this page, *at the default zoomlevel*. (if you're not at the default zoom level, hit Ctrl + 0 to get there, and reload the page.)
(Reporter)

Comment 2

3 years ago
I can't reproduce this in the Ubuntu-provided Firefox release, because that version has H.264 support compiled in (via gstreamer I think), which means twitter shows you that instead of this flashplugin fallback.

But Mozilla's own Firefox releases for Linux don't have H.264 support and hence are able to reproduce this. I've tested the following builds & confirmed they're affected:
  Nightly 38.0a1 (2015-01-30)
  Latest Firefox release tarball (downloaded from Mozilla), version 35.01
  Nightly 23.0a1 (2013-04-11)

(So, not a regression, or not a recent regression.)
Whiteboard: [platform-rel-Twitter]

Updated

2 years ago
platform-rel: --- → ?

Comment 3

2 years ago
dholbert, is this still an issue nowadays?
Flags: needinfo?(dholbert)
(Reporter)

Comment 4

2 years ago
No, it's not an issue, I think.

(In particular: Twitter always served us content that worked correctly, if we support H.264. And I can't find a build that doesn't support H.264 these days. I tested current Firefox Nightly (50), current Release (47), and a slightly-older release (45). So, in practice, this isn't an issue. If someone can test a build without H.264 support, they might discover that this is still broken; but on the other hand, it might not be too big of a deal since that represents a very small fraction of our users at this point, I think.)

Hence, WORKSFORME.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(dholbert)
Resolution: --- → WORKSFORME

Comment 5

2 years ago
Thank you! :-)
platform-rel: ? → -
(Reporter)

Comment 6

2 years ago
(In reply to Daniel Holbert [:dholbert] from comment #4)
> I can't find a build that doesn't support H.264 these days.

(Side note: over on bug 1167641, I realized that I am still able to turn off H.264 support & trigger flash fallback on a different site, if I toggle about:config pref "media.mp4.enabled = false".  BUT, that doesn't help with reproducing this bug here -- if I turn off that pref, this bug's video just gets a disclaimer over the top of it saying "This browser does not support video playback."  So, I suspect twitter may have just dropped their flash fallback for this particular means of embedding videos.)
You need to log in before you can comment on or make changes to this bug.