[Messages] It's impossible to scroll participants list in group MMS report panel

VERIFIED FIXED in 2.2 S6 (20feb)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: azasypkin, Assigned: julienw)

Tracking

({regression})

unspecified
2.2 S6 (20feb)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [sms-sprint-2.2S5])

Attachments

(3 attachments, 2 obsolete attachments)

STR (checked on the latest master PVT eng-build):

* Create or open MMS group thread (> 5 participants on Flame);
* Long tap on any message and choose "View message report";
* Try to scroll participants list;

Expected result: user can scroll up to see entire participants list;

Actual result: user can't scroll up.

Note: this may be the same issue that we see in bug 1127773, so it's reasonable to check with the regression window we have in bug 1127773 first.
QA Contact: bzumwalt
Central Regression Window:

Posting Central build regression window now and leaving regressionwindow-wanted keyword in expectation of posting Mozilla-Inbound regression window on Monday.

Last working central build:
Device: Flame 2.2
Build ID: 20150103174341
Gaia: c2bf20d23851d5fda9f8f0ef0267db5f49152376
Gecko: 9703c61caf74
Version: 37.0a1 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

First broken central build:
Device: Flame 2.2
Build ID: 20150103200341
Gaia: c2bf20d23851d5fda9f8f0ef0267db5f49152376
Gecko: 55f3224d7513
Version: 37.0a1 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0


Working Gaia with Broken Gecko issue DOES occur:
Gaia: c2bf20d23851d5fda9f8f0ef0267db5f49152376
Gecko: 55f3224d7513

Working Gecko with Broken Gaia issue does NOT occur:
Gaia: c2bf20d23851d5fda9f8f0ef0267db5f49152376
Gecko: 9703c61caf74


Central Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=9703c61caf74&tochange=55f3224d7513


Issue appears to stem from a Gecko commit merged from Mozilla-Inbound
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
triage: based on the sympton it should be blocking. If comment 3 is the case, Julien/Oleg please help to set this to corresponding component.
blocking-b2g: 2.2? → 2.2+
Assignee

Comment 3

4 years ago
Kats, assigning to you as it's likely the same than bug 1127773.

note: to force sending a MMS (instead of sending several SMS), you just need to add a subject.
Component: Gaia::SMS → Panning and Zooming
Product: Firefox OS → Core
Is there a way to simulate this without having a SIM in the device? (I haven't tried following the STR yet so maybe there's an obvious way)
Assignee: nobody → bugmail.mozilla
Assignee

Comment 5

4 years ago
Yes, you can try to send a MMS even without a SIM :) it will be in error but will still create a thread with a message in it.

I actually enable flight mode on my device because I don't want to send the message ;)
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Mozilla-Inbound Regression Window:

Last working Mozilla-Inbound build:
Device: Flame 2.2
BuildID: 20150102135212
Gaia: 698e6e8a098cc060b26cd6f25171633c4c7e739d
Gecko: 9689b122bc76
Version: 37.0a1 (2.2)
Firmware: V18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

First broken Mozilla-Inbound build:
Device: Flame 2.2
BuildID: 20150102140811
Gaia: 698e6e8a098cc060b26cd6f25171633c4c7e739d
Gecko: 8564f04a6f14
Version: 37.0a1 (2.2)
Firmware: V18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0


Working Gaia with Broken Gecko issue DOES occur:
Gaia: 698e6e8a098cc060b26cd6f25171633c4c7e739d
Gecko: 8564f04a6f14

Working Gecko with Broken Gaia issue does NOT occur:
Gaia: 698e6e8a098cc060b26cd6f25171633c4c7e739d
Gecko: 9689b122bc76


Mozilla-Inbound Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=9689b122bc76&tochange=8564f04a6f14


Issue appears to occur due to bug 928833
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Kartikaya, can you take a look at this please? Looks like it might have been caused by the work done on bug 928833.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(bugmail.mozilla)
Yes, it's already assigned to me.
Flags: needinfo?(bugmail.mozilla)
I can repro on master, even with the patch I posted on bug 1127773. It's likely a separate issue, I am investigating.
Blocks: 928833
See Also: 1127773
I think this is happening because the element in question has pointer-events:none set on it [1]. Taking that out seems to fix the problem. Julien, do you know what the purpose of that pointer-events:none is? I think it's expected that setting pointer-events:none on the element with overflow:scroll (or in this case overflow-y:auto) will make it non-scrollable because all the touch events will fall through to the content underneath instead.

[1] https://github.com/mozilla-b2g/gaia/blob/9093ccc0c909c6977bbaaf570c0728bc12d75a3d/apps/sms/style/report_view.css#L74
Flags: needinfo?(felash)
Assignee

Comment 11

4 years ago
I think we set it because we reuse a component that handles click, and we don't want clicks to be handled. But you're right, I think it should be fixed at our side.

Does that mean you changed something in Gecko that would change how it works?
Assignee: bugmail.mozilla → nobody
Component: Panning and Zooming → Gaia::SMS
Flags: needinfo?(felash)
Product: Core → Firefox OS
Yeah, in Gecko we weren't properly respecting pointer-events:none in the APZ code before we turned on the event regions code in bug 928833. Now we do (at least in theory) so it's not surprising that it will expose some latent issues in other parts of the code.
Assignee

Updated

4 years ago
Assignee: nobody → felash
Posted file github PR v1 (obsolete) —
Assignee

Comment 14

4 years ago
Comment on attachment 8559179 [details] [review]
github PR v1

I remembered we used "pointer-events: none" to remove the highlight color. But I think it's better to just remove the color for links that don't have href. Maybe can use :link/:visited instead, but the fact we'd have to use both just to besure makes me thing a[href] is better.

Pavel, what do you think? How can we check this doesn't break other apps?

As an alternative I could use "pointer-events: none" on ".report-view > ul.contact-list a" but this looks like an hack.
Attachment #8559179 - Flags: review?(schung)
Attachment #8559179 - Flags: review?(pivanov)
Assignee

Updated

4 years ago
Whiteboard: [sms-sprint-2.2S5]
Assignee

Comment 15

4 years ago
Comment on attachment 8559179 [details] [review]
github PR v1

I've been thinking, I think we need the highlight without href sometimes.

I'll think of a cleaner way and will come back tomorrow with a better solution.
Attachment #8559179 - Flags: review?(schung)
Attachment #8559179 - Flags: review?(pivanov)
Posted file github PR v2 (obsolete) —
Posted file github PR v3
Assignee

Updated

4 years ago
Attachment #8559179 - Attachment description: [PullReq] julienw:1128093-remove-active-color-for-links-without-href to mozilla-b2g:master → github PR v1
Assignee

Updated

4 years ago
Attachment #8559878 - Attachment description: [PullReq] julienw:1128093-remove-active-color-for-links-without-href-v2 to mozilla-b2g:master → github PR v2
Assignee

Updated

4 years ago
Attachment #8559902 - Attachment description: [PullReq] julienw:1128093-remove-active-color-for-links-without-href-v3 to mozilla-b2g:master → github PR v3
Assignee

Comment 18

4 years ago
Hey Steve, here are 3 proposals, I'd like your advice here.

v1 and v2 are simple but IMO they workaround the issue.
v3 is IMO reducing the technical debt but is more complex.

If I had to choose I'd do v1 on v2.2 and v3 on master. What do you think?
Flags: needinfo?(schung)
(In reply to Julien Wajsberg [:julienw] from comment #18)
> Hey Steve, here are 3 proposals, I'd like your advice here.
> 
> v1 and v2 are simple but IMO they workaround the issue.
> v3 is IMO reducing the technical debt but is more complex.
> 
> If I had to choose I'd do v1 on v2.2 and v3 on master. What do you think?

I totally agree that v1 is better than v2 and appropriate for v2.2. For master, it looks nice for further report view polishing.
Flags: needinfo?(schung)
Assignee

Comment 21

4 years ago
Comment on attachment 8561684 [details] [review]
[PullReq] julienw:1128093-v2.2-remove-active-color-for-links-without-href to mozilla-b2g:v2.2

Hey Steve, here is the solution v1 for the branch v2.2.
Attachment #8561684 - Flags: review?(schung)
Assignee

Comment 22

4 years ago
Comment on attachment 8559902 [details] [review]
github PR v3

I think it's ready for review :)
Tell me what you think !
Attachment #8559902 - Flags: review?(schung)
Assignee

Updated

4 years ago
Attachment #8559878 - Attachment is obsolete: true
Assignee

Updated

4 years ago
Attachment #8559179 - Attachment is obsolete: true
Comment on attachment 8561684 [details] [review]
[PullReq] julienw:1128093-v2.2-remove-active-color-for-links-without-href to mozilla-b2g:v2.2

This one for 2.2 is good enough, thanks!
Attachment #8561684 - Flags: review?(schung) → review+
Assignee

Updated

4 years ago
See Also: → 928833
Assignee

Comment 24

4 years ago
Comment on attachment 8561684 [details] [review]
[PullReq] julienw:1128093-v2.2-remove-active-color-for-links-without-href to mozilla-b2g:v2.2

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): bug 928833 -- more exactly, this bug fixed a bad behavior in gecko that we used, so it revealed a bug in the SMS code.
[User impact] if declined: We can't scroll the recipients in the report view, in a group MMS scenario, when there are more than 2-3 recipients.
[Testing completed]: yes (manual)
[Risk to taking this patch] (and alternatives if risky): low
[String changes made]: none
Attachment #8561684 - Flags: approval-gaia-v2.2?
Attachment #8561684 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
Target Milestone: --- → 2.2 S6 (20feb)
Comment on attachment 8559902 [details] [review]
github PR v3

Some nits on github, but overall looks good, thanks!
Attachment #8559902 - Flags: review?(schung) → review+
Assignee

Comment 27

4 years ago
NI Eitan for an accessibility question at [1].

[1] https://github.com/mozilla-b2g/gaia/pull/27977/files#r24564074
Flags: needinfo?(eitan)
Assignee

Comment 29

4 years ago
OK, github f*** up my URL. I'll let you find the comment, Eitan :p
Replied, don't use role=presentation there, leave the li alone like you say.

Sorry for the late response.
Flags: needinfo?(eitan)
Assignee

Comment 31

4 years ago
Thans Eitan !
NI me to land the patch when I have time.
Flags: needinfo?(felash)
Assignee

Comment 32

4 years ago
master: https://github.com/mozilla-b2g/gaia/commit/31ac1cd7a029d5e46dd7c92537b5c973c5d9826e
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(felash)
Resolution: --- → FIXED
Assignee

Updated

4 years ago
Depends on: 1214677

Comment 33

4 years ago
According to the STR of Comment 0, this bug has been verified as pass on latest Flame KK v2.2 & v2.5 and Aries KK v2.5.

Actual result: User can scroll up to see entire participants list.

See attachment: verified_Flame KK v2.5.3gp
Reproduce rate: 0/6

Device: Flame KK v2.2 (Pass)
Build ID               20151014032504
Gaia Revision          885647d92208fb67574ced44004ab2f29d23cb45
Gaia Date              2015-10-07 13:05:24
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/8645d434a70d
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151014.064817
Firmware Date          Wed Oct 14 06:48:28 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Flame KK v2.5 (Pass)
Build ID               20151014150203
Gaia Revision          c64d6e345aa477f2a24b676e84a47020a00d015d
Gaia Date              2015-10-14 15:54:16
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/4f4615ffec6a6a7ec40ff61ffda90a46c53f8d31
Gecko Version          44.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151014.183316
Firmware Date          Wed Oct 14 18:33:28 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Aries KK v2.5 (Pass)
Build ID               20151014225836
Gaia Revision          c64d6e345aa477f2a24b676e84a47020a00d015d
Gaia Date              2015-10-14 15:54:16
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/4f4615ffec6a6a7ec40ff61ffda90a46c53f8d31
Gecko Version          44.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151014.221548
Firmware Date          Wed Oct 14 22:15:56 UTC 2015
Bootloader             s1

Updated

4 years ago
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+], [MGSEI-Triage+]
You need to log in before you can comment on or make changes to this bug.