Last Comment Bug 1128105 - Meeting Accept/Decline buttons not appearing on incoming meeting invitations
: Meeting Accept/Decline buttons not appearing on incoming meeting invitations
Status: RESOLVED FIXED
: regression
Product: Calendar
Classification: Client Software
Component: E-mail based Scheduling (iTIP/iMIP) (show other bugs)
: Lightning 4.0.0.1
: All All
-- normal (vote)
: 4.0.0.1
Assigned To: [:MakeMyDay]
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-01-30 15:49 PST by David Edwards
Modified: 2015-02-02 13:54 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
lightning_notify_broken.png (6.82 KB, image/png)
2015-01-31 05:20 PST, David Edwards
no flags Details
lightning_notify_working.png (7.95 KB, image/png)
2015-01-31 05:22 PST, David Edwards
no flags Details
lightning_broken.log (3.21 KB, text/plain)
2015-01-31 05:23 PST, David Edwards
no flags Details
lightning_fixed.log (1.04 KB, text/x-log)
2015-01-31 05:25 PST, David Edwards
no flags Details
FixImipBarRegression-V1.diff (1.26 KB, patch)
2015-01-31 12:36 PST, [:MakeMyDay]
philipp: review+
Details | Diff | Splinter Review

Description User image David Edwards 2015-01-30 15:49:49 PST
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Firefox/38.0 SeaMonkey/2.35a1
Build ID: 20150130003001

Steps to reproduce:

The bug is actually in Lightning, but it doesn't let me select that.

When I receive a meeting invite, the Lightning Notification bar appears, but it has no working Accept/Decline buttons.


Actual results:

I couldn't accept the meeting.

There was an exception in the Web Console pointing me to line 198 of imip-bar.js.
        imipBar.resetButtons();

This is apparently not a function.



Expected results:

I should have been able to accept or decline the meeting.

After commenting out the line 198, it works as expected.
Comment 1 User image David Edwards 2015-01-30 15:51:55 PST
Commenting out line 198 of imip-bar.js works for me.
Comment 2 User image [:MakeMyDay] 2015-01-31 01:38:17 PST
This is workingwell here with TB 38 + Lightning 4.0. Can you please post all messages you have in the error log when reproducing this? Do you have any other extensions enabled?
Comment 3 User image [:MakeMyDay] 2015-01-31 01:46:19 PST
Can you please enable calendar.debug.log, calendar.debug.log.verbose and javascript.options.ShowInConsole if any of this is not already enabled before checking the log?
Comment 4 User image David Edwards 2015-01-31 04:46:01 PST
No other mail extensions, but being Seamonkey I've several plugins and extensions in the browser.

But given the simplicity and efficacy of my work round, I doubt that these are relevant.

Nevertheless I will re-instate the line of code that causes the problem, and gather the logs as you request.
Comment 5 User image David Edwards 2015-01-31 05:20:31 PST
Created attachment 8557470 [details]
lightning_notify_broken.png

Screenshot of malfunctioning Lightning notification bar.
Comment 6 User image David Edwards 2015-01-31 05:22:19 PST
Created attachment 8557471 [details]
lightning_notify_working.png

Screenshot of Lightning Notification Bar after commenting out the failing line in imip-bar.js
Comment 7 User image David Edwards 2015-01-31 05:23:53 PST
Created attachment 8557472 [details]
lightning_broken.log

stderr and stdout from Seamonkey with calendar.debug.* true with the offending line 198 active.
Comment 8 User image David Edwards 2015-01-31 05:25:04 PST
Created attachment 8557474 [details]
lightning_fixed.log

stderr and stdout from Seamonkey with calendar.debug.* true with the offending line 198 commented out.
Comment 9 User image [:MakeMyDay] 2015-01-31 12:35:23 PST
Confirming the issue. I've tested previously on an old version - sorry for the inconvinience.
Comment 10 User image [:MakeMyDay] 2015-01-31 12:36:29 PST
Created attachment 8557525 [details] [diff] [review]
FixImipBarRegression-V1.diff

Note You need to log in before you can comment on or make changes to this bug.